aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-09-12 00:40:59 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-09-12 00:40:59 +0800
commitd3a783727e3d8db94f6b27376c49da9bf68bae90 (patch)
treecebaa8fa26c184c6dfb17ca91580d65997cb1ae0 /ftp
parent7e0abd2f59c8b7959b825b5115aed74712b77fc4 (diff)
downloadfreebsd-ports-gnome-d3a783727e3d8db94f6b27376c49da9bf68bae90.tar.gz
freebsd-ports-gnome-d3a783727e3d8db94f6b27376c49da9bf68bae90.tar.zst
freebsd-ports-gnome-d3a783727e3d8db94f6b27376c49da9bf68bae90.zip
- Fix LICENSE
- Add LICENSE_FILE - Switch to options helpers
Diffstat (limited to 'ftp')
-rw-r--r--ftp/frox/Makefile28
-rw-r--r--ftp/frox/files/patch-lib-sstrlib-sstr_io.c6
-rw-r--r--ftp/frox/files/patch-src-bsd.c16
-rw-r--r--ftp/frox/files/patch-src-cache.c8
-rw-r--r--ftp/frox/files/patch-src_frox.conf12
5 files changed, 36 insertions, 34 deletions
diff --git a/ftp/frox/Makefile b/ftp/frox/Makefile
index 8eb9dd89b338..e1ccd4689a1b 100644
--- a/ftp/frox/Makefile
+++ b/ftp/frox/Makefile
@@ -12,10 +12,12 @@ MASTER_SITES= http://www.hollo.org/frox/download/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Transparent FTP proxy with caching support
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake tar:bzip2
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-configfile=${PREFIX}/etc/frox.conf
USE_RC_SUBR= frox
SUB_FILES= pkg-message
@@ -23,14 +25,12 @@ SUB_FILES= pkg-message
PORTDOCS= SECURITY CREDITS ChangeLog FAQ.html FAQ-1.html FAQ-2.html \
FAQ-3.html FAQ-4.html FAQ-5.html FAQ-6.html FAQ-7.html \
FAQ-8.html
-PLIST_FILES= sbin/frox ${EXAMPLESDIR:S,${PREFIX}/,,}/frox.conf \
- man/man1/frox.1.gz man/man5/frox.conf.5.gz
-
-PKGMESSAGE= ${WRKDIR}/pkg-message
+PORTEXAMPLES= *
+PLIST_FILES= sbin/frox \
+ man/man1/frox.1.gz \
+ man/man5/frox.conf.5.gz
-CONFIGURE_ARGS= --enable-configfile=${PREFIX}/etc/frox.conf
-
-OPTIONS_DEFINE= VIRUS_SCAN HTTP_CACHE LOCAL_CACHE CCP ROOT_RUN DOCS
+OPTIONS_DEFINE= VIRUS_SCAN HTTP_CACHE LOCAL_CACHE CCP ROOT_RUN DOCS EXAMPLES
OPTIONS_DEFAULT= HTTP_CACHE CCP
OPTIONS_RADIO= PFILTER
@@ -45,19 +45,23 @@ CCP_DESC= Ftp-proxy style command control programs
ROOT_RUN_DESC= Allow frox running as root (not recomended)
IPFILTER_CONFIGURE_ENABLE= ipfilter
-PF_CPPFLAGS= -DPF
+PF_CPPFLAGS= -DPF
VIRUS_SCAN_CONFIGURE_ENABLE= virus-scan
HTTP_CACHE_CONFIGURE_ENABLE= http-cache
LOCAL_CACHE_CONFIGURE_ENABLE= local-cache
-CCP_CONFIGURE_ENABLE= ccp
+CCP_CONFIGURE_ENABLE= ccp
ROOT_RUN_CONFIGURE_ARGS= run-as-root
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/frox ${STAGEDIR}${PREFIX}/sbin
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/src/frox.conf ${STAGEDIR}${EXAMPLESDIR}/frox.conf
${INSTALL_MAN} ${WRKSRC}/doc/frox.man ${STAGEDIR}${MANPREFIX}/man/man1/frox.1
${INSTALL_MAN} ${WRKSRC}/doc/frox.conf.man ${STAGEDIR}${MANPREFIX}/man/man5/frox.conf.5
+
+do-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/src/frox.conf ${STAGEDIR}${EXAMPLESDIR}/frox.conf
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}
diff --git a/ftp/frox/files/patch-lib-sstrlib-sstr_io.c b/ftp/frox/files/patch-lib-sstrlib-sstr_io.c
index 9bd3fc87a30b..b985c0b9e9be 100644
--- a/ftp/frox/files/patch-lib-sstrlib-sstr_io.c
+++ b/ftp/frox/files/patch-lib-sstrlib-sstr_io.c
@@ -1,5 +1,5 @@
---- lib/sstrlib/sstr_io.c.orig 2005-02-04 13:24:55.000000000 +0300
-+++ lib/sstrlib/sstr_io.c 2007-12-14 18:07:15.000000000 +0300
+--- lib/sstrlib/sstr_io.c.orig 2005-02-04 10:24:55 UTC
++++ lib/sstrlib/sstr_io.c
@@ -26,6 +26,7 @@
#include <sys/ioctl.h>
#include <unistd.h>
@@ -8,7 +8,7 @@
#include "sstr.h"
#include "sstr_private.h"
-@@ -61,8 +62,14 @@
+@@ -61,8 +62,14 @@ int sstr_apprintf(sstr * p, const char *
int sstr_append_read(int fd, sstr * p, int cnt)
{
int i;
diff --git a/ftp/frox/files/patch-src-bsd.c b/ftp/frox/files/patch-src-bsd.c
index ca2735065b4f..2f90ecba530c 100644
--- a/ftp/frox/files/patch-src-bsd.c
+++ b/ftp/frox/files/patch-src-bsd.c
@@ -1,5 +1,5 @@
---- src/bsd.c.orig Fri Feb 4 20:54:55 2005
-+++ src/bsd.c Wed Jul 25 01:25:16 2007
+--- src/bsd.c.orig 2005-02-04 10:24:55 UTC
++++ src/bsd.c
@@ -30,6 +30,16 @@
#error --enable-transparent-data not supported under BSD
#endif
@@ -17,7 +17,7 @@
#ifdef IPFILTER
#include <fcntl.h>
#include <sys/ioctl.h>
-@@ -51,6 +61,11 @@
+@@ -51,6 +61,11 @@ int os_init(void)
if(natfd < 0)
write_log(ERROR, "Unable to initialise IPFilter");
#endif
@@ -29,7 +29,7 @@
return 0;
}
-@@ -61,6 +76,11 @@
+@@ -61,6 +76,11 @@ int os_init(void)
int get_orig_dest(int fd, struct sockaddr_in *addr)
{
socklen_t len;
@@ -41,11 +41,10 @@
#ifdef IPFILTER
struct natlookup nat;
struct sockaddr_in from;
-@@ -99,6 +119,31 @@
- addr->sin_family = AF_INET;
+@@ -100,6 +120,31 @@ int get_orig_dest(int fd, struct sockadd
return r2;
}
-+#endif
+ #endif
+#ifdef PF
+ getpeername(fd, (struct sockaddr *) &from, &len);
+ memset(&nl, 0, sizeof(struct pfioc_natlook));
@@ -70,6 +69,7 @@
+ return r2;
+ }
+ }
- #endif
++#endif
memcpy(addr, &to, len);
return r1;
+ }
diff --git a/ftp/frox/files/patch-src-cache.c b/ftp/frox/files/patch-src-cache.c
index 0f2ebeab247c..234d61301042 100644
--- a/ftp/frox/files/patch-src-cache.c
+++ b/ftp/frox/files/patch-src-cache.c
@@ -3,9 +3,9 @@ Apply patch
Patch attached with submission follows:
---- src/cache.c.orig 2008-03-12 16:56:10.000000000 +0200
-+++ src/cache.c 2008-03-12 16:56:10.000000000 +0200
-@@ -364,7 +364,7 @@
+--- src/cache.c.orig 2005-02-04 10:24:55 UTC
++++ src/cache.c
+@@ -364,7 +364,7 @@ int setup_fileinfo(sstr * filename)
int code;
sstr *msg;
@@ -14,5 +14,3 @@ Patch attached with submission follows:
send_ccommand("SIZE", sstr_buf(filename));
get_message(&code, &msg);
if(code / 100 != 2) {
-
-
diff --git a/ftp/frox/files/patch-src_frox.conf b/ftp/frox/files/patch-src_frox.conf
index 759e89f28612..f47c53b0f18c 100644
--- a/ftp/frox/files/patch-src_frox.conf
+++ b/ftp/frox/files/patch-src_frox.conf
@@ -1,5 +1,5 @@
---- src/frox.conf.orig Sat Apr 5 17:30:35 2003
-+++ src/frox.conf Mon Apr 7 15:05:51 2003
+--- src/frox.conf.orig 2005-02-04 10:24:55 UTC
++++ src/frox.conf
@@ -18,16 +18,13 @@
# commented out to listen on all local IPs.
#
@@ -18,7 +18,7 @@
# Whether to run from inetd. You should still define Port above, but
# it isn't used for much.
#
-@@ -44,7 +41,7 @@
+@@ -44,7 +41,7 @@ BindToDevice eth0
# comment this out and copy resolver libraries into the chroot jail instead.
# See FAQ section 3.2 for details.
#
@@ -27,7 +27,7 @@
# Another ftp proxy to forward on to. Frox will contact this ftp
# proxy, and send it a login name of the form "user@host:port" where
-@@ -64,8 +61,8 @@
+@@ -73,8 +70,8 @@ ResolvLoadHack wontresolve.doesntexist.a
# you really want to run as root (not a good idea) you must say so
# specifically, and have compiled with --enable-run-as-root.
#
@@ -38,7 +38,7 @@
# This is frox's working directory - it must be specified. Temporary
# files and sockets will be created here. If you are using local
-@@ -74,8 +71,8 @@
+@@ -83,8 +80,8 @@ ResolvLoadHack wontresolve.doesntexist.a
# also chroot to this dir on startup. To avoid this you must specifically
# set DontChroot to Yes.
#
@@ -47,5 +47,5 @@
+WorkingDir /tmp
+DontChroot Yes
- # Logging level. 0=No logging. 5=Critical errors only. 10= All errors.
+ # Logging level. 0=No logging. 5=Critical errors only. 10= All errors.
# 15=Errors, other important stuf. 20= Errors, connections, cache