aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-03-27 22:57:59 +0800
committertijl <tijl@FreeBSD.org>2016-03-27 22:57:59 +0800
commit15fde8d043c6a14c4c0afdc5b4202bd64ec72d0d (patch)
tree95ab4f85bf7bf8cb530a6cecc47ac36a30dcab4b /ftp
parenta26520fa167c589a0112b75f59be7ad0d3255855 (diff)
downloadfreebsd-ports-gnome-15fde8d043c6a14c4c0afdc5b4202bd64ec72d0d.tar.gz
freebsd-ports-gnome-15fde8d043c6a14c4c0afdc5b4202bd64ec72d0d.tar.zst
freebsd-ports-gnome-15fde8d043c6a14c4c0afdc5b4202bd64ec72d0d.zip
- Update security/gnutls to 3.4.10.
- Rename the LIBDANE option DANE because that's the name of the protocol supported by libgnutls-dane and gnutls-cli. Also clarify the option description. - Add an IDN option. - libgnutls-openssl has been removed in 3.4. Some ports used this library in their LIB_DEPENDS but no port actually required it. - Some old API functions have been removed. Ports that used these have been updated or patched to use the new API. - Add a patch to print/cups to prevent overlinking of libgnutls.so. - Bump PORTREVISION on dependent ports. net-im/jabber: This port used the old API to give users fine grained control over which crypto algorithms were used via a configuration file. It's not immediately obvious how to port this to the new API so the port always uses the defaults now. www/hydra: Mark BROKEN. This uses more removed calls than the other ports, is said to be alpha quality and not fully functional and has been abandoned 10 years ago. PR: 207768 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile1
-rw-r--r--ftp/filezilla/Makefile1
-rw-r--r--ftp/lftp/Makefile1
-rw-r--r--ftp/wget/Makefile1
-rw-r--r--ftp/wput/Makefile2
-rw-r--r--ftp/wzdftpd/Makefile2
-rw-r--r--ftp/wzdftpd/files/patch-libwzd-core_wzd_tls.c52
7 files changed, 58 insertions, 2 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 37193d159a38..8c43c0dd0a83 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= curl
PORTVERSION= 7.48.0
+PORTREVISION= 1
CATEGORIES= ftp www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
diff --git a/ftp/filezilla/Makefile b/ftp/filezilla/Makefile
index aa833ef042f5..6bb399c04310 100644
--- a/ftp/filezilla/Makefile
+++ b/ftp/filezilla/Makefile
@@ -2,6 +2,7 @@
PORTNAME= filezilla
PORTVERSION= 3.16.0
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= SF/${PORTNAME}/FileZilla_Client/${PORTVERSION}
DISTNAME= FileZilla_${PORTVERSION}_src
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
index 131261234129..1a4a5a0d3ba2 100644
--- a/ftp/lftp/Makefile
+++ b/ftp/lftp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lftp
PORTVERSION= 4.6.5
+PORTREVISION= 1
CATEGORIES= ftp ipv6
MASTER_SITES= http://lftp.yar.ru/ftp/ \
http://lftp.yar.ru/ftp/old/ \
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index e3aef0c1a8ce..3919c9f1e39b 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wget
DISTVERSION= 1.16.3
+PORTREVISION= 1
CATEGORIES= ftp www ipv6
MASTER_SITES= GNU
diff --git a/ftp/wput/Makefile b/ftp/wput/Makefile
index 579963891f81..1ac2bfcad0c8 100644
--- a/ftp/wput/Makefile
+++ b/ftp/wput/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wput
PORTVERSION= 0.6.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= ftp
MASTER_SITES= SF
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
index 69c67fc9c159..e0c3ce743971 100644
--- a/ftp/wzdftpd/Makefile
+++ b/ftp/wzdftpd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wzdftpd
PORTVERSION= 0.8.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= ftp ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-sources/${PORTNAME}-${PORTVERSION:R}
diff --git a/ftp/wzdftpd/files/patch-libwzd-core_wzd_tls.c b/ftp/wzdftpd/files/patch-libwzd-core_wzd_tls.c
new file mode 100644
index 000000000000..6c755286c6e3
--- /dev/null
+++ b/ftp/wzdftpd/files/patch-libwzd-core_wzd_tls.c
@@ -0,0 +1,52 @@
+--- libwzd-core/wzd_tls.c.orig 2007-10-25 17:25:33 UTC
++++ libwzd-core/wzd_tls.c
+@@ -946,19 +946,13 @@ int tls_exit(void)
+
+ static gnutls_session initialize_tls_session(gnutls_connection_end con_end)
+ {
+- /* Allow connections to servers that have OpenPGP keys as well.
+- */
+- const int cert_type_priority[3] = { GNUTLS_CRT_X509, GNUTLS_CRT_OPENPGP, 0 };
+-
+ gnutls_session session;
+
+ gnutls_init(&session, con_end);
+
+- /* avoid calling all the priority functions, since the defaults
+- * are adequate.
++ /* Allow connections to servers that have OpenPGP keys as well.
+ */
+- gnutls_set_default_priority(session);
+- gnutls_certificate_type_set_priority(session, cert_type_priority);
++ gnutls_priority_set_direct(session, "NORMAL:+CTYPE-OPENPGP", NULL);
+
+ gnutls_credentials_set(session, GNUTLS_CRD_CERTIFICATE, x509_cred);
+
+@@ -1001,27 +995,6 @@ int tls_auth (const char *type, wzd_cont
+ }
+
+ /** \todo XXX parse TLS cipher names */
+- {
+- /** Note that the priority is set on the client. The server does not use
+- * the algorithm's priority except for disabling algorithms that were not
+- * specified.
+- */
+- const int cipherPriority[] =
+- {
+- GNUTLS_CIPHER_ARCFOUR_128,
+- GNUTLS_CIPHER_3DES_CBC,
+- GNUTLS_CIPHER_AES_128_CBC,
+- GNUTLS_CIPHER_AES_256_CBC,
+- GNUTLS_CIPHER_ARCFOUR_40,
+-#if ( (LIBGNUTLS_VERSION_MAJOR > 1) || (LIBGNUTLS_VERSION_MINOR >= 3) )
+- GNUTLS_CIPHER_RC2_40_CBC,
+- GNUTLS_CIPHER_DES_CBC,
+-#endif
+- 0
+- };
+-
+- gnutls_cipher_set_priority(session, cipherPriority);
+- }
+
+ /* ensure socket is non-blocking */
+ #if defined(_MSC_VER) || (defined(__CYGWIN__) && defined(WINSOCK_SUPPORT))