aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
committertijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
commit6255104baacfdd2c23e07550f90d2f9a7020ca87 (patch)
tree516db145d6cf5fd4d2666f811272aad577272ac5 /ftp
parent016de2316ed16336a58b66dafd7f332614a041ac (diff)
downloadfreebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.gz
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.zst
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.zip
- Replace Mk/bsd.linux-apps.mk and Mk/bsd.linux-rpm.mk with
Mk/Uses/linux.mk. - Replace USE_LINUX=yes with USES+=linux and USE_LINUX=(.*) with USES+=linux:\1 in all ports. - Replace USE_LINUX_APPS with USE_LINUX in all ports. - Use INSTALL_SCRIPT instead of INSTALL_PROGRAM to install scripts in some ports. - When USE_LINUX_RPM is defined, simplify the way DISTFILES and EXTRACT_ONLY are defined. - Remove BRANDELF_DIRS and BRANDELF_FILES handling. In the very rare cases that it is still necessary ports can run ${BRANDELF} from post-patch. - Remove AUTOMATIC_PLIST handling. Only one port used it. - Fix Linux MASTER_SITES. - Replace OVERRIDE_LINUX_BASE_PORT and OVERRIDE_LINUX_NONBASE_PORTS with default versions framework. - bsd.port.mk: - Move Linux related bits to Uses/linux.mk, except USE_LINUX_PREFIX. - Put USE_LINUX_PREFIX handling after USES processing. - Define DOCSDIR, DATADIR, etc. after handling USE_LINUX_PREFIX so it can give these variables a different default value. - When a package needs to run Linux ldconfig check before installation if Linux support is enabled. - emulators/linux_base-*: - Use USES=linux and remove duplication. - Remove files/lp. FreeBSD or CUPS lp(1) should work. - Remove files/yp.conf. No longer seems to be used. - Remove pkg-deinstall and move pkg-install into pkg-plist. - Update pkg-descr and pkg-message. - Fix handling of ldconfig cache in pkg-plist. - devel/fb-adb: Use a Linux shell to run a Linux script but patch the script to use FreeBSD mkdir so mkdir -p $path creates $path and not /compat/linux/$path. PR: 211645 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'ftp')
-rw-r--r--ftp/linux-c6-curl/Makefile14
-rw-r--r--ftp/linux-f10-curl/Makefile20
2 files changed, 11 insertions, 23 deletions
diff --git a/ftp/linux-c6-curl/Makefile b/ftp/linux-c6-curl/Makefile
index 1377ec72bed6..50733dec5d43 100644
--- a/ftp/linux-c6-curl/Makefile
+++ b/ftp/linux-c6-curl/Makefile
@@ -5,26 +5,22 @@ PORTNAME= curl
PORTVERSION= 7.19.7
PORTREVISION= 6
CATEGORIES= ftp linux
-DISTFILES= curl-${PORTVERSION}-${RPMVERSION}.${LINUX_RPM_ARCH}.rpm
-LIB_DISTFILES= libcurl-${PORTVERSION}-${RPMVERSION}.${LINUX_RPM_ARCH}.rpm
-MASTER_SITES= CENTOS_LINUX
+LIB_DISTFILES= lib${DISTNAME}${EXTRACT_SUFX}
+SRC_DISTFILES= ${DISTNAME}${SRC_SUFX}:SOURCE
MAINTAINER= emulation@FreeBSD.org
COMMENT= Command line tool for transferring files with URL syntax (Linux CentOS ${LINUX_DIST_VER})
CONFLICTS= linux-curl-[0-9]* linux-f10-curl-[0-9]*
-ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= c6
-USE_LINUX_APPS= openldap libssh2 # cyrus-sasl2
+USES= linux:c6
+USE_LINUX= openldap libssh2 # cyrus-sasl2
USE_LINUX_RPM= nolib
RPMVERSION= 52.el6
-BRANDELF_FILES= usr/bin/curl
USE_LDCONFIG= yes
-DOCSDIR= usr/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= BUGS COPYING FEATURES README TODO CHANGES FAQ MANUAL RESOURCES TheArtOfHttpScripting
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
.include <bsd.port.mk>
diff --git a/ftp/linux-f10-curl/Makefile b/ftp/linux-f10-curl/Makefile
index 285aab8a9439..b76a87805c00 100644
--- a/ftp/linux-f10-curl/Makefile
+++ b/ftp/linux-f10-curl/Makefile
@@ -5,32 +5,24 @@ PORTNAME= curl
PORTVERSION= 7.19.6
PORTREVISION= 1
CATEGORIES= ftp linux
-MASTER_SITES= LOCAL/ehaupt/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
-DISTFILES= curl-${PORTVERSION}-${RPMVERSION}.i386.rpm \
- libcurl-${PORTVERSION}-${RPMVERSION}.i386.rpm
+LIB_DISTFILES= lib${DISTNAME}${EXTRACT_SUFX}
+SRC_DISTFILES= ${DISTNAME}${SRC_SUFX}:SOURCE
MAINTAINER= emulation@FreeBSD.org
COMMENT= Command line tool for transferring files with URL syntax (Linux Fedora 10)
CONFLICTS= linux-curl-[0-9]* linux-f8-curl-[0-9]*
-USE_LINUX= f10
-USE_LINUX_RPM= yes
-USE_LINUX_APPS= cyrus-sasl2 openldap
+USES= linux:f10
+USE_LINUX= cyrus-sasl2 openldap
+USE_LINUX_RPM= nolib
RPMVERSION= 2.fc10
USE_LDCONFIG= yes
-BRANDELF_FILES= usr/bin/curl
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
PLIST_FILES= usr/bin/curl usr/lib/libcurl.so.4 usr/lib/libcurl.so.4.1.1 \
usr/share/man/man1/curl.1.gz
-DOCSDIR= usr/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= BUGS COPYING FEATURES README TODO CHANGES FAQ MANUAL RESOURCES TheArtOfHttpScripting
-.if defined(PACKAGE_BUILDING)
-SRC_DISTFILES= curl-${PORTVERSION}-${RPMVERSION}.src.rpm
-ALWAYS_KEEP_DISTFILES= YES
-.endif
-
.include <bsd.port.mk>