aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2004-08-18 14:55:39 +0800
committerobrien <obrien@FreeBSD.org>2004-08-18 14:55:39 +0800
commit7be1b69b2b54597afdaae0088cdd22e984763897 (patch)
treeba18817a4f2596bf87ecd9d4685412bc4fe2dc4e /ftp
parentdb8a37d77dd7293d733f56b5d91679524fef4f36 (diff)
downloadfreebsd-ports-gnome-7be1b69b2b54597afdaae0088cdd22e984763897.tar.gz
freebsd-ports-gnome-7be1b69b2b54597afdaae0088cdd22e984763897.tar.zst
freebsd-ports-gnome-7be1b69b2b54597afdaae0088cdd22e984763897.zip
Go ahead and rush the 2004-08-30 deprecatation since the port is now
FORBIDDEN due to a vulerability. I really don't think anyone is going to put the effort into un-FORBIDDENing it.
Diffstat (limited to 'ftp')
-rw-r--r--ftp/lukemftpd/Makefile70
-rw-r--r--ftp/lukemftpd/distinfo2
-rw-r--r--ftp/lukemftpd/files/patch-ftpd.c53
-rw-r--r--ftp/lukemftpd/files/patch-logutmp.c20
-rw-r--r--ftp/lukemftpd/files/patch-logwtmp.c34
-rw-r--r--ftp/lukemftpd/files/patch-src-Makefile.in12
-rw-r--r--ftp/lukemftpd/pkg-descr22
-rw-r--r--ftp/lukemftpd/pkg-plist5
8 files changed, 0 insertions, 218 deletions
diff --git a/ftp/lukemftpd/Makefile b/ftp/lukemftpd/Makefile
deleted file mode 100644
index bc739230a6aa..000000000000
--- a/ftp/lukemftpd/Makefile
+++ /dev/null
@@ -1,70 +0,0 @@
-# New ports collection makefile for: lukemftpd
-# Date created: 12 April 2001
-# Whom: Anders Nordby <anders@fix.no>
-#
-# $FreeBSD$
-#
-
-PORTNAME= lukemftpd
-PORTVERSION= 1.1
-PORTREVISION= 1
-CATEGORIES= ftp ipv6
-MASTER_SITES= ftp://ftp.netbsd.org/pub/NetBSD/misc/lukemftp/old/ \
- ftp://ftp.nuug.no/pub/anders/distfiles/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Enhanced ftp server from NetBSD
-
-FORBIDDEN= http://vuxml.freebsd.org/c4b025bb-f05d-11d8-9837-000c41e2cdad.html
-DEPRECATED= "lukemftpd was renamed to tnftpd"
-EXPIRATION_DATE=2004-08-30
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-
-DOCS= ChangeLog README THANKS
-
-MAN5= ftpd.conf.5 ftpusers.5
-MAN8= ftpd.8
-
-FIXPREFIX= ftpd.8 ftpd.conf.5 ftpusers.5
-
-pre-patch:
-.for f in ${FIXPREFIX}
- ${REINPLACE_CMD} -e "s@^\.Dq Pa /etc@.Dq Pa ${PREFIX}/etc@g; \
- s@^\.Pa /etc@.Pa ${PREFIX}/etc@g; \
- s@^\.It Pa /etc/@.It Pa ${PREFIX}/etc/@g; \
- s@^\.Ss /etc/@.Ss ${PREFIX}/etc/@g; \
- s@^\.Sx /etc/@.Sx ${PREFIX}/etc/@g; \
- s@^\.Bl -tag -width /etc/@.Bl -tag -width ${PREFIX}/etc/@g; \
- s@${PREFIX}/etc/shells@/etc/shells@g; \
- s@${PREFIX}/etc/pwd.db@/etc/pwd.db@g" \
- ${WRKSRC}/src/${f}
-.endfor
- ${REINPLACE_CMD} -e \
- "s@^#define _DEFAULT_CONFDIR \"/etc\"@#define _DEFAULT_CONFDIR \"${PREFIX}/etc\"@" \
- ${WRKSRC}/src/pathnames.h
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/ftpd ${PREFIX}/libexec/ftpd
- ${INSTALL_MAN} ${WRKSRC}/src/ftpd.8 ${PREFIX}/man/man8
- ${INSTALL_MAN} ${WRKSRC}/src/ftpd.conf.5 ${PREFIX}/man/man5
- ${INSTALL_MAN} ${WRKSRC}/src/ftpusers.5 ${PREFIX}/man/man5
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/lukemftpd
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/lukemftpd/
-.endfor
-.endif
-
-post-install:
- @${ECHO_MSG} "================================================================================"
- @${ECHO_MSG} "This port relies on a number of configuration files in ${PREFIX}/etc."
- @${ECHO_MSG} "At the very least, create a ftpusers file with the usernams of users you don't"
- @${ECHO_MSG} "want to connect (root, toor, etc.). This will allow non-listed users to log in."
- @${ECHO_MSG} "Copying /etc/ftpusers to ${PREFIX}/etc/ftpusers should be sufficient."
- @${ECHO_MSG}
- @${ECHO_MSG} "See the man files for more information. The man- and configuration files for"
- @${ECHO_MSG} "FreeBSD's built-in ftpd can also be of use as examples/additional info."
- @${ECHO_MSG} "================================================================================"
-
-.include <bsd.port.mk>
diff --git a/ftp/lukemftpd/distinfo b/ftp/lukemftpd/distinfo
deleted file mode 100644
index 4838c77c34bf..000000000000
--- a/ftp/lukemftpd/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (lukemftpd-1.1.tar.gz) = 66286f1cc17988964c6e224e196c7b94
-SIZE (lukemftpd-1.1.tar.gz) = 162161
diff --git a/ftp/lukemftpd/files/patch-ftpd.c b/ftp/lukemftpd/files/patch-ftpd.c
deleted file mode 100644
index c0d938fb5fc4..000000000000
--- a/ftp/lukemftpd/files/patch-ftpd.c
+++ /dev/null
@@ -1,53 +0,0 @@
---- src/ftpd.c.orig Wed Apr 25 08:25:43 2001
-+++ src/ftpd.c Sat May 26 16:46:35 2001
-@@ -102,6 +102,8 @@
- * FTP server.
- */
-
-+#define NO_UTMP
-+
- #define FTP_NAMES
-
- #include "lukemftpd.h"
-@@ -780,9 +782,9 @@
- if (logged_in) {
- #ifdef NO_UTMP
- if (dowtmp)
-- logwtmp(ttyline, "", "");
-+ ftpd_logwtmp(ttyline, "", "");
- if (doutmp)
-- logout(utmp.ut_line);
-+ ftpd_logout(utmp.ut_line);
- #endif /* NO_UTMP */
- }
- /* reset login state */
-@@ -912,7 +914,7 @@
- /* open wtmp before chroot */
- #ifdef NO_UTMP
- if (dowtmp)
-- logwtmp(ttyline, pw->pw_name, remotehost);
-+ ftpd_logwtmp(ttyline, pw->pw_name, remotehost);
-
- /* open utmp before chroot */
- if (doutmp) {
-@@ -921,7 +923,7 @@
- (void)strncpy(utmp.ut_name, pw->pw_name, sizeof(utmp.ut_name));
- (void)strncpy(utmp.ut_host, remotehost, sizeof(utmp.ut_host));
- (void)strncpy(utmp.ut_line, ttyline, sizeof(utmp.ut_line));
-- login(&utmp);
-+ ftpd_login(&utmp);
- }
- #endif /* NO_UTMP */
-
-@@ -2155,9 +2157,9 @@
- if (logged_in) {
- #ifdef NO_UTMP
- if (dowtmp)
-- logwtmp(ttyline, "", "");
-+ ftpd_logwtmp(ttyline, "", "");
- if (doutmp)
-- logout(utmp.ut_line);
-+ ftpd_logout(utmp.ut_line);
- #endif /* NO_UTMP */
- #ifdef KERBEROS
- if (!notickets && krbtkfile_env)
diff --git a/ftp/lukemftpd/files/patch-logutmp.c b/ftp/lukemftpd/files/patch-logutmp.c
deleted file mode 100644
index 357d69928773..000000000000
--- a/ftp/lukemftpd/files/patch-logutmp.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/logutmp.c.old Sat May 26 16:07:13 2001
-+++ src/logutmp.c Sat May 26 16:07:39 2001
-@@ -45,7 +45,7 @@
- */
-
- void
--login(const UTMP *ut)
-+ftpd_login(const UTMP *ut)
- {
- UTMP ubuf;
-
-@@ -85,7 +85,7 @@
- }
-
- int
--logout(const char *line)
-+ftpd_logout(const char *line)
- {
- UTMP ut;
- int rval;
diff --git a/ftp/lukemftpd/files/patch-logwtmp.c b/ftp/lukemftpd/files/patch-logwtmp.c
deleted file mode 100644
index fde4bf76212e..000000000000
--- a/ftp/lukemftpd/files/patch-logwtmp.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/logwtmp.c.old Sat May 26 16:08:11 2001
-+++ src/logwtmp.c Sat May 26 16:15:20 2001
-@@ -46,10 +46,30 @@
- * after login, but before logout).
- */
- void
--logwtmp(const char *line, const char *name, const char *host)
-+ftpd_logwtmp(const char *line, const char *name, const char *host)
- {
- struct utmp ut;
- struct stat buf;
-+
-+ if (strlen(host) > UT_HOSTSIZE) {
-+ struct addrinfo hints, *res;
-+ int error;
-+ static char hostbuf[BUFSIZ];
-+
-+ memset(&hints, 0, sizeof(hints));
-+ hints.ai_family = PF_UNSPEC;
-+ error = getaddrinfo(host, NULL, &hints, &res);
-+ if (error)
-+ host = "invalid hostname";
-+ else {
-+ getnameinfo(res->ai_addr, res->ai_addrlen,
-+ hostbuf, sizeof(hostbuf), NULL, 0,
-+ NI_NUMERICHOST);
-+ host = hostbuf;
-+ if (strlen(host) > UT_HOSTSIZE)
-+ host[UT_HOSTSIZE] = '\0';
-+ }
-+ }
-
- if (fd < 0 && (fd = open(_PATH_WTMP, O_WRONLY|O_APPEND, 0)) < 0)
- return;
diff --git a/ftp/lukemftpd/files/patch-src-Makefile.in b/ftp/lukemftpd/files/patch-src-Makefile.in
deleted file mode 100644
index c10312d6b11e..000000000000
--- a/ftp/lukemftpd/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/Makefile.in.old Sat May 26 16:33:44 2001
-+++ src/Makefile.in Sat May 26 16:34:32 2001
-@@ -22,8 +22,7 @@
- INSTALL = @INSTALL@
-
- PROG = ftpd
--OBJS = cmds.o conf.o ftpd.o ftpcmd.o popen.o @LSOBJS@
--# removed: logutmp.o logwtmp.o
-+OBJS = cmds.o conf.o ftpd.o ftpcmd.o popen.o logutmp.o logwtmp.o @LSOBJS@
-
- all: ${PROG}
-
diff --git a/ftp/lukemftpd/pkg-descr b/ftp/lukemftpd/pkg-descr
deleted file mode 100644
index 05d7d9a3ccd8..000000000000
--- a/ftp/lukemftpd/pkg-descr
+++ /dev/null
@@ -1,22 +0,0 @@
-`lukemftpd' is what many users affectionately call the enhanced ftp
-server in NetBSD.
-
-The enhancements over the standard ftp server in 4.4BSD include:
-
- * command line options:
- + allow override of directory used by anonymous ftp (-a)
- + optional change of directory for configuration files (-c)
- + check whether a user would be granted access (-C)
- + specify email address for display messages (-e)
- + change hostname advertised as (-h, -H)
- + specify data port to listen on (-P)
- + keep track of the number of users logged in (-q, -Q)
- + permanently drop privileges (-r)
- + specify version advertised (-V)
- + log wu-ftpd style `xferlog' entries to syslog (-X)
-
- * IPv6 support (from the KAME project).
-
- * +++ (see README)
-
-- Anders Nordby <anders@fix.no>
diff --git a/ftp/lukemftpd/pkg-plist b/ftp/lukemftpd/pkg-plist
deleted file mode 100644
index 3fdb146811c6..000000000000
--- a/ftp/lukemftpd/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-libexec/ftpd
-%%PORTDOCS%%share/doc/lukemftpd/ChangeLog
-%%PORTDOCS%%share/doc/lukemftpd/README
-%%PORTDOCS%%share/doc/lukemftpd/THANKS
-%%PORTDOCS%%@dirrm share/doc/lukemftpd