aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-16 21:23:13 +0800
committermat <mat@FreeBSD.org>2016-06-16 21:23:13 +0800
commita4af234af8f51d40eb998ed6d368ccea401a3302 (patch)
treef5237f7173e7b9a5cbac11e6a57f460d84e79314 /ftp
parent56be8553fe553c4526347278fbdd90ec4156eb14 (diff)
downloadfreebsd-ports-gnome-a4af234af8f51d40eb998ed6d368ccea401a3302.tar.gz
freebsd-ports-gnome-a4af234af8f51d40eb998ed6d368ccea401a3302.tar.zst
freebsd-ports-gnome-a4af234af8f51d40eb998ed6d368ccea401a3302.zip
Fix usage of WITH_OPENSSL_BASE, WITH_OPENSSL_PORT and OPENSSL_PORT.
WITH_OPENSSL_* can't be set after bsd.port.pre.mk. Fold all other usage into using SSL_DEFAULT == foo PR: 210149 Submitted by: mat Exp-run by: antoine Sponsored by: The FreeBSD Foundation, Absolight Differential Revision: https://reviews.freebsd.org/D6577
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 890067ac0361..9ce59ff60b76 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -32,7 +32,10 @@ THREADED_RESOLVER_DESC= Threaded DNS resolver
TLS_SRP_DESC= TLS-SRP (Secure Remote Password) support
LOCALBASE?= /usr/local
-.if defined(WITH_OPENSSL_PORT) || (!defined(WITH_OPENSSL_BASE) && exists(${LOCALBASE}/lib/libcrypto.so))
+
+.include <${PORTSDIR}/Mk/bsd.default-versions.mk>
+
+.if ${SSL_DEFAULT} != base
OPTIONS_DEFAULT+= GSSAPI_NONE
.else
OPTIONS_DEFAULT+= GSSAPI_BASE
@@ -148,11 +151,11 @@ IGNORE= only supports TLS-SRP with either OpenSSL or GnuTLS
IGNORE= only supports LDAPS with SSL
.endif
-.if ${PORT_OPTIONS:MGSSAPI_BASE} && ${PORT_OPTIONS:MOPENSSL} && (defined(WITH_OPENSSL_PORT) || (!defined(WITH_OPENSSL_BASE) && exists(${LOCALBASE}/lib/libcrypto.so)))
+.if ${PORT_OPTIONS:MGSSAPI_BASE} && ${PORT_OPTIONS:MOPENSSL} && ${SSL_DEFAULT} != base
IGNORE= GSSAPI_BASE is not compatible with OpenSSL from ports. Use other GSSAPI options or OpenSSL from base system
.endif
-.if defined(OPENSSL_PORT) && ${OPENSSL_PORT} == "security/libressl"
+.if ${SSL_DEFAULT} == libressl
.if ${PORT_OPTIONS:MGSSAPI_BASE} && ${PORT_OPTIONS:MOPENSSL}
IGNORE= GSSAPI_BASE is not compatible with LibreSSL. Use other GSSAPI options
.endif