aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-06-02 03:03:15 +0800
committerijliao <ijliao@FreeBSD.org>2001-06-02 03:03:15 +0800
commita6e7e0cb7ef7988fa8c1fb576d79f0b2160e607c (patch)
treefcb92a40569eb37b3bf0cd167df686df1b140490 /ftp
parent86669f665ad5ae8a1fa7c616b97ad8593cbd893c (diff)
downloadfreebsd-ports-gnome-a6e7e0cb7ef7988fa8c1fb576d79f0b2160e607c.tar.gz
freebsd-ports-gnome-a6e7e0cb7ef7988fa8c1fb576d79f0b2160e607c.tar.zst
freebsd-ports-gnome-a6e7e0cb7ef7988fa8c1fb576d79f0b2160e607c.zip
add vcheck
Automatically check for and download most recent versions of software
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/vcheck/Makefile23
-rw-r--r--ftp/vcheck/distinfo1
-rw-r--r--ftp/vcheck/pkg-comment1
-rw-r--r--ftp/vcheck/pkg-descr6
-rw-r--r--ftp/vcheck/pkg-plist3
6 files changed, 35 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index bd5401e65a23..c3e33a95adad 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -45,6 +45,7 @@
SUBDIR += ruby-curl
SUBDIR += sftp
SUBDIR += spegla
+ SUBDIR += vcheck
SUBDIR += vsftpd
SUBDIR += wget
SUBDIR += wu-ftpd
diff --git a/ftp/vcheck/Makefile b/ftp/vcheck/Makefile
new file mode 100644
index 000000000000..3a9d02e40389
--- /dev/null
+++ b/ftp/vcheck/Makefile
@@ -0,0 +1,23 @@
+# ex:ts=8
+# New ports collection makefile for: vcheck
+# Date created: Jun 1, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= vcheck
+PORTVERSION= 1.0.3
+CATEGORIES= ftp
+MASTER_SITES= http://www.tu-ilmenau.de/~gomar/stuff/vcheck/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= vcheck.1
+
+.include <bsd.port.mk>
diff --git a/ftp/vcheck/distinfo b/ftp/vcheck/distinfo
new file mode 100644
index 000000000000..022bc7b93ceb
--- /dev/null
+++ b/ftp/vcheck/distinfo
@@ -0,0 +1 @@
+MD5 (vcheck-1.0.3.tar.gz) = 060df6b06acc28733a8897659b2f301a
diff --git a/ftp/vcheck/pkg-comment b/ftp/vcheck/pkg-comment
new file mode 100644
index 000000000000..506791b78156
--- /dev/null
+++ b/ftp/vcheck/pkg-comment
@@ -0,0 +1 @@
+Automatically check for and download most recent versions of software
diff --git a/ftp/vcheck/pkg-descr b/ftp/vcheck/pkg-descr
new file mode 100644
index 000000000000..eb98cd86176f
--- /dev/null
+++ b/ftp/vcheck/pkg-descr
@@ -0,0 +1,6 @@
+vcheck is a rather complex and highly configurable PERL script designed to
+automate the process of checking for and downloading most recent versions of
+software packages at HTTP or FTP locations. The script is self-documenting,
+and this in a rather comprehensive fashion.
+
+WWW: http://www.tu-ilmenau.de/~gomar/stuff/vcheck/
diff --git a/ftp/vcheck/pkg-plist b/ftp/vcheck/pkg-plist
new file mode 100644
index 000000000000..d7d97931259c
--- /dev/null
+++ b/ftp/vcheck/pkg-plist
@@ -0,0 +1,3 @@
+bin/vcheck
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/vcheck/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/vcheck