aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-05-11 03:08:09 +0800
committersat <sat@FreeBSD.org>2006-05-11 03:08:09 +0800
commit421c7d50e2c7371d840017f4be6b7c7de39475a3 (patch)
tree621a73d3eb160e5978227ed9624828381225c431 /ftp
parent5dc35b54e917f2a10d18567b58e765ec78429ed4 (diff)
downloadfreebsd-ports-gnome-421c7d50e2c7371d840017f4be6b7c7de39475a3.tar.gz
freebsd-ports-gnome-421c7d50e2c7371d840017f4be6b7c7de39475a3.tar.zst
freebsd-ports-gnome-421c7d50e2c7371d840017f4be6b7c7de39475a3.zip
- Update to 0.98.1
- Fix epiphany extension PR: ports/96665 Submitted by: sat Approved by: osa (co-mentor)
Diffstat (limited to 'ftp')
-rw-r--r--ftp/gwget/Makefile22
-rw-r--r--ftp/gwget/distinfo6
-rw-r--r--ftp/gwget/files/patch-src__gwget_data.c10
-rw-r--r--ftp/gwget/files/patch-src_gwget_data.c10
-rw-r--r--ftp/gwget/files/patch-src_main.c42
-rw-r--r--ftp/gwget/files/patch-src_wget-log.c63
-rw-r--r--ftp/gwget/pkg-plist14
7 files changed, 34 insertions, 133 deletions
diff --git a/ftp/gwget/Makefile b/ftp/gwget/Makefile
index c08e9823f9d2..a27cdf956e24 100644
--- a/ftp/gwget/Makefile
+++ b/ftp/gwget/Makefile
@@ -1,16 +1,15 @@
-# New ports collection makefile for: gwget
-# Date created: 1 November 2004
-# Whom: Radek Kozlowski <radek@raadradd.com>
+# New ports collection makefile for: gwget
+# Date created: 1 November 2004
+# Whom: Radek Kozlowski <radek@raadradd.com>
#
# $FreeBSD$
#
PORTNAME= gwget
-PORTVERSION= 0.95
-PORTREVISION= 1
+PORTVERSION= 0.98.1
CATEGORIES= ftp www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= gnome2
MAINTAINER= radek@raadradd.com
@@ -20,14 +19,15 @@ RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui
+USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui gconf2
GNU_CONFIGURE= yes
USE_X_PREFIX= yes
+USE_GETTEXT= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-Wl,-export-dynamic -L${LOCALBASE}/lib"
GCONF_SCHEMAS= gwget.schemas
-EPHY_VER= 1.6
+EPHY_VER?= 2.14
.include <bsd.port.pre.mk>
@@ -39,11 +39,11 @@ WITH_EPIPHANY= yes
BUILD_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
CONFIGURE_ARGS+= --enable-epiphany-extension \
--with-epiphany-version=${EPHY_VER}
-PLIST_SUB+= EPIPHANY:="" \
+PLIST_SUB+= EPIPHANY="" \
VERSION="${EPHY_VER}"
.else
CONFIGURE_ARGS+= --disable-epiphany-extension
-PLIST_SUB+= EPIPHANY:="@comment "
+PLIST_SUB+= EPIPHANY="@comment "
.endif # defined(WITH_EPIPHANY)
post-patch:
diff --git a/ftp/gwget/distinfo b/ftp/gwget/distinfo
index fb0e550ac6b3..8fa243199408 100644
--- a/ftp/gwget/distinfo
+++ b/ftp/gwget/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gwget-0.95.tar.bz2) = 8c268fb6c8f724f0e1971c033ada9c47
-SHA256 (gnome2/gwget-0.95.tar.bz2) = 2b54f05a006e9d8413b27fd981872b09a7a73bf24b64090f126e4866d30e6318
-SIZE (gnome2/gwget-0.95.tar.bz2) = 418952
+MD5 (gnome2/gwget-0.98.1.tar.bz2) = d09c1b589e2240cb7391d58eb2c8cc83
+SHA256 (gnome2/gwget-0.98.1.tar.bz2) = 7f15caa8a618a0e56803f1d234db8b77a6b2a9d72c4c1d4f371487480443488b
+SIZE (gnome2/gwget-0.98.1.tar.bz2) = 427105
diff --git a/ftp/gwget/files/patch-src__gwget_data.c b/ftp/gwget/files/patch-src__gwget_data.c
new file mode 100644
index 000000000000..bd72cc75b9fe
--- /dev/null
+++ b/ftp/gwget/files/patch-src__gwget_data.c
@@ -0,0 +1,10 @@
+--- ./src/gwget_data.c.orig Tue Dec 6 19:54:41 2005
++++ ./src/gwget_data.c Tue May 2 17:55:45 2006
+@@ -35,6 +35,7 @@
+ #include "main_window_cb.h"
+ #include "utils.h"
+ #include "systray.h"
++#include <netinet/in.h>
+
+
+
diff --git a/ftp/gwget/files/patch-src_gwget_data.c b/ftp/gwget/files/patch-src_gwget_data.c
deleted file mode 100644
index ba61130fc9e4..000000000000
--- a/ftp/gwget/files/patch-src_gwget_data.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/gwget_data.c.orig Thu May 19 19:02:00 2005
-+++ src/gwget_data.c Thu May 19 19:02:38 2005
-@@ -31,6 +31,7 @@
- #include "main_window_cb.h"
- #include "utils.h"
- #include "systray.h"
-+#include <netinet/in.h>
-
- #include <config.h>
-
diff --git a/ftp/gwget/files/patch-src_main.c b/ftp/gwget/files/patch-src_main.c
deleted file mode 100644
index 32dd57953a4b..000000000000
--- a/ftp/gwget/files/patch-src_main.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- src/main.c.orig Sat Apr 2 22:26:21 2005
-+++ src/main.c Sat Apr 2 22:52:48 2005
-@@ -120,6 +120,7 @@
- Args *args_original = (Args*)client_data;
- int argc_original = (*args_original).argc;
- char **argv_original = (*args_original).argv;
-+ int i, iPos, iL, iSize;
-
- int argc;
- char **argv;
-@@ -166,13 +167,12 @@
- argc = argc_original + 2;
- argv = g_malloc0(sizeof(char*)*argc);
-
-- int iPos = -1;
-- int i;
-+ iPos = -1;
- for (i=0;i<argc_original;i++)
- if (strcmp(argv_original[i],"--force-tray-only") != 0) {
- iPos++;
-- int iL = strlen(argv_original[i]);
-- int iSize = sizeof(char)*iL;
-+ iL = strlen(argv_original[i]);
-+ iSize = sizeof(char)*iL;
- argv[iPos] = g_malloc0(iSize);
- strcpy(argv[iPos],argv_original[i]);
- }
-@@ -191,12 +191,13 @@
- static void
- gnome_session_join(int argc,char *argv[])
- {
-+ GnomeClient* client;
- Args *args = g_malloc(sizeof(Args));
-
- (*args).argc = argc;
- (*args).argv = argv;
-
-- GnomeClient* client = gnome_master_client();
-+ client = gnome_master_client();
-
- gnome_client_set_restart_style(client,GNOME_RESTART_IF_RUNNING);
- gtk_signal_connect(GTK_OBJECT(client),"save_yourself",
diff --git a/ftp/gwget/files/patch-src_wget-log.c b/ftp/gwget/files/patch-src_wget-log.c
deleted file mode 100644
index 84565ee69416..000000000000
--- a/ftp/gwget/files/patch-src_wget-log.c
+++ /dev/null
@@ -1,63 +0,0 @@
---- src/wget-log.c.orig Sat Apr 2 23:05:09 2005
-+++ src/wget-log.c Sat Apr 2 23:31:55 2005
-@@ -58,11 +58,13 @@
- static int
- wget_log_process_line (GwgetData *gwgetdata)
- {
-- if (gwgetdata->line == NULL)
-- return 0;
--
- gchar *p;
- struct stat file_stat;
-+ char *sName;
-+ int iL;
-+
-+ if (gwgetdata->line == NULL)
-+ return 0;
-
- switch (gwgetdata->state) {
- case DL_NOT_CONNECTED:
-@@ -72,10 +74,10 @@
- * filesystem filename and set gwgetdata->filename
- */
- if (strstr(gwgetdata->line," => `")) {
-- int iL = strlen(gwgetdata->line);
-+ iL = strlen(gwgetdata->line);
- gwgetdata->line[iL-1] = 0; // Chop the final '
-
-- char *sName = gwgetdata->line;
-+ sName = gwgetdata->line;
- /*
- * Now sName contains the whole pathname. No filename can
- * contain '/' so the following search for the last component
-@@ -272,11 +274,14 @@
-
- void
- wget_log_read_log_line(GwgetData *gwgetdata) {
-+ char c;
-+ int iRes, iBlockCount, iWritePos;
-+ gchar *buffer;
-+
- g_free(gwgetdata->line);
- gwgetdata->line = NULL;
--
-- char c;
-- int iRes = read(gwgetdata->log_fd,&c,1);
-+
-+ iRes = read(gwgetdata->log_fd,&c,1);
-
- if (iRes < 1) {
- /*
-@@ -286,9 +291,9 @@
- return;
- }
-
-- int iBlockCount = 1;
-- gchar *buffer = g_malloc(sizeof(gchar)*(iBlockCount*BLOCK_SIZE));
-- int iWritePos = 0;
-+ iBlockCount = 1;
-+ buffer = g_malloc(sizeof(gchar)*(iBlockCount*BLOCK_SIZE));
-+ iWritePos = 0;
-
- buffer[iWritePos++] = c;
- while (c != '\n') {
diff --git a/ftp/gwget/pkg-plist b/ftp/gwget/pkg-plist
index 99bb01ac0be8..9acae1f95472 100644
--- a/ftp/gwget/pkg-plist
+++ b/ftp/gwget/pkg-plist
@@ -9,8 +9,10 @@ include/gwget/systray.h
include/gwget/utils.h
include/gwget/wget-log.h
libdata/bonobo/servers/GNOME_Gwget.server
-%%EPIPHANY:%%lib/epiphany-%%VERSION%%/extensions/libgwgetextension.so
-%%EPIPHANY:%%lib/epiphany-%%VERSION%%/extensions/gwget.xml
+%%EPIPHANY%%lib/epiphany/%%VERSION%%/extensions/libgwgetextension.a
+%%EPIPHANY%%lib/epiphany/%%VERSION%%/extensions/libgwgetextension.la
+%%EPIPHANY%%lib/epiphany/%%VERSION%%/extensions/libgwgetextension.so
+%%EPIPHANY%%lib/epiphany/%%VERSION%%/extensions/gwget.xml
share/gnome/applications/gwget.desktop
share/gnome/gwget/about.glade
share/gnome/gwget/downloading.png
@@ -24,6 +26,7 @@ share/gnome/gwget/newdownload.png
share/gnome/gwget/preferences.glade
share/gnome/idl/GNOME_Gwget.idl
share/gnome/pixmaps/gwget.png
+share/locale/ar/LC_MESSAGES/gwget.mo
share/locale/bg/LC_MESSAGES/gwget.mo
share/locale/ca/LC_MESSAGES/gwget.mo
share/locale/cs/LC_MESSAGES/gwget.mo
@@ -40,6 +43,7 @@ share/locale/it/LC_MESSAGES/gwget.mo
share/locale/ja/LC_MESSAGES/gwget.mo
share/locale/lt/LC_MESSAGES/gwget.mo
share/locale/mk/LC_MESSAGES/gwget.mo
+share/locale/ne/LC_MESSAGES/gwget.mo
share/locale/nl/LC_MESSAGES/gwget.mo
share/locale/pa/LC_MESSAGES/gwget.mo
share/locale/pl/LC_MESSAGES/gwget.mo
@@ -52,9 +56,11 @@ share/locale/sk/LC_MESSAGES/gwget.mo
share/locale/sq/LC_MESSAGES/gwget.mo
share/locale/sv/LC_MESSAGES/gwget.mo
share/locale/tr/LC_MESSAGES/gwget.mo
+share/locale/uk/LC_MESSAGES/gwget.mo
share/locale/zh_CN/LC_MESSAGES/gwget.mo
share/locale/zh_TW/LC_MESSAGES/gwget.mo
@dirrm include/gwget
-%%EPIPHANY:%%@dirrmtry lib/epiphany-%%VERSION%%/extensions
-%%EPIPHANY:%%@dirrmtry lib/epiphany-%%VERSION%%
+%%EPIPHANY%%@dirrmtry lib/epiphany/%%VERSION%%/extensions
+%%EPIPHANY%%@dirrmtry lib/epiphany/%%VERSION%%
+%%EPIPHANY%%@dirrmtry lib/epiphany
@dirrm share/gnome/gwget