aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-27 19:31:10 +0800
committermat <mat@FreeBSD.org>2016-06-27 19:31:10 +0800
commit82a234f5c1d92aab301c663775859cfec043f06b (patch)
tree1b037def670694489104abae09b8b8337f0e5a08 /ftp
parentce1eac9e2628f5b9255c5e38be1f9bf9c1183409 (diff)
downloadfreebsd-ports-gnome-82a234f5c1d92aab301c663775859cfec043f06b.tar.gz
freebsd-ports-gnome-82a234f5c1d92aab301c663775859cfec043f06b.tar.zst
freebsd-ports-gnome-82a234f5c1d92aab301c663775859cfec043f06b.zip
Replace bsd.openssl.mk with USES=ssl
Add a qa hint about needing, or not, USES=ssl. Fix ports doing silly things, like including bsd.openssl.mk directly. PR: 210322 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D6866
Diffstat (limited to 'ftp')
-rw-r--r--ftp/vsftpd-ext/Makefile2
-rw-r--r--ftp/vsftpd/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/ftp/vsftpd-ext/Makefile b/ftp/vsftpd-ext/Makefile
index e893ac94faf3..64f9d426d8ee 100644
--- a/ftp/vsftpd-ext/Makefile
+++ b/ftp/vsftpd-ext/Makefile
@@ -57,7 +57,7 @@ VSFTPD_NO_OPTIMIZED= -e "s|-O2 ||"
.endif
.if ${PORT_OPTIONS:MVSFTPD_SSL} && !defined(WITHOUT_SSL)
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+USES+= ssl
SSL_SUFFIX= -ssl
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
diff --git a/ftp/vsftpd/Makefile b/ftp/vsftpd/Makefile
index 790cded898d2..d6a2e8e14570 100644
--- a/ftp/vsftpd/Makefile
+++ b/ftp/vsftpd/Makefile
@@ -33,7 +33,7 @@ STACKPROTECTOR_DESC= Build with stack-protector
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MVSFTPD_SSL} && !defined(WITHOUT_SSL)
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+USES+= ssl
SSL_SUFFIX= -ssl
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}