aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2011-03-15 21:34:26 +0800
committervd <vd@FreeBSD.org>2011-03-15 21:34:26 +0800
commit91b06c24395aa78e3b2843d017230a49e3fb2b6c (patch)
tree0c475379fb9c42b02825fbcf9178856ae9201e1d /ftp
parent320b0f0ad36c0d4c7560268e915483e8a19fc192 (diff)
downloadfreebsd-ports-gnome-91b06c24395aa78e3b2843d017230a49e3fb2b6c.tar.gz
freebsd-ports-gnome-91b06c24395aa78e3b2843d017230a49e3fb2b6c.tar.zst
freebsd-ports-gnome-91b06c24395aa78e3b2843d017230a49e3fb2b6c.zip
Add optional dependency to libidn
Previously if libidn was present during wget configure time then wget would have picked it up, but the dependency would not have been recorded in the installed packages database thus later upgrade or deinstallation of libidn would break wget. Spotted by: sergey.dyatko@gmail.com, wenheping@gmail.com
Diffstat (limited to 'ftp')
-rw-r--r--ftp/wget/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index 7bffa5cf22e3..d9f8f71314a9 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wget
DISTVERSION= 1.12
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= ftp www ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= wget
@@ -27,7 +27,8 @@ MAKE_JOBS_SAFE= yes
OPTIONS= GNUTLS "Support for SSL via GnuTLS" Off \
IPV6 "Support for IPv6" On \
NLS "Native Language Support with gettext" On \
- OPENSSL "Support for SSL via OpenSSL" On
+ OPENSSL "Support for SSL via OpenSSL" On \
+ IDN "Support IDN (Internationalized Domain Names)" On
.include <bsd.port.pre.mk>
@@ -65,6 +66,13 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB= NLS="@comment "
.endif
+.if !defined(WITHOUT_IDN)
+LIB_DEPENDS+= idn:${PORTSDIR}/dns/libidn
+CONFIGURE_ARGS+=--enable-iri --with-libidn=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--disable-iri
+.endif
+
MAN1= wget.1
INFO= wget