aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-04-17 05:46:01 +0800
committerclement <clement@FreeBSD.org>2004-04-17 05:46:01 +0800
commit9e590cc59ee464f5760df525f6f750ff1669f47b (patch)
tree4358473862eddc49591188a8c1a71a7fa2aa7ccb /ftp
parent5f838040b663f991ad0c17ffd327a95e513622a9 (diff)
downloadfreebsd-ports-gnome-9e590cc59ee464f5760df525f6f750ff1669f47b.tar.gz
freebsd-ports-gnome-9e590cc59ee464f5760df525f6f750ff1669f47b.tar.zst
freebsd-ports-gnome-9e590cc59ee464f5760df525f6f750ff1669f47b.zip
- Add MySQL support
Diffstat (limited to 'ftp')
-rw-r--r--ftp/moftpd/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/ftp/moftpd/Makefile b/ftp/moftpd/Makefile
index 5379d3b16966..aba61efae4ec 100644
--- a/ftp/moftpd/Makefile
+++ b/ftp/moftpd/Makefile
@@ -19,7 +19,15 @@ GNU_CONFIGURE= yes
USE_OPENSSL= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
-CONFIGURE_ENV+= LIBS=-lcrypt
+CONFIGURE_ENV+= LIBS="${LIBS}"
MAN8= moftpd.8 moftpadmin.8
+LIBS+= -lcrypt
+
+.if defined(WITH_MYSQL)
+CFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib/mysql
+.else
+CONFIGURE_ARGS+= --without-sql
+.endif
.include <bsd.port.mk>