aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-07-04 12:25:13 +0800
committerwill <will@FreeBSD.org>2000-07-04 12:25:13 +0800
commitd230a0283443d7a54e8e05d1759cc8e9b1e41b99 (patch)
tree7f1d9b9806340081e2c439c263126b1ad8e7c16d /ftp
parent157312b97a675d1b1d6c4616919aa2e5495b517e (diff)
downloadfreebsd-ports-gnome-d230a0283443d7a54e8e05d1759cc8e9b1e41b99.tar.gz
freebsd-ports-gnome-d230a0283443d7a54e8e05d1759cc8e9b1e41b99.tar.zst
freebsd-ports-gnome-d230a0283443d7a54e8e05d1759cc8e9b1e41b99.zip
Add ftpq, a ftp upload queue manager.
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/ftpq/Makefile21
-rw-r--r--ftp/ftpq/distinfo1
-rw-r--r--ftp/ftpq/pkg-comment1
-rw-r--r--ftp/ftpq/pkg-descr8
-rw-r--r--ftp/ftpq/pkg-plist1
6 files changed, 33 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 862ce91aa9d4..3b6170bf2e53 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -9,6 +9,7 @@
SUBDIR += ftpfind
SUBDIR += ftplocate
SUBDIR += ftpmirror
+ SUBDIR += ftpq
SUBDIR += ftpsearch
SUBDIR += ftptool
SUBDIR += gftp
diff --git a/ftp/ftpq/Makefile b/ftp/ftpq/Makefile
new file mode 100644
index 000000000000..15e7227c88cd
--- /dev/null
+++ b/ftp/ftpq/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: ftpq
+# Date created: Mon 03 Jul 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= ftpq
+PORTVERSION= 0.06
+CATEGORIES= ftp
+MASTER_SITES= http://www.tranchant.freeserve.co.uk/software/
+
+MAINTAINER= ports@FreeBSD.org
+
+MAN1= ftpq.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ftpq ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/ftpq.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/ftp/ftpq/distinfo b/ftp/ftpq/distinfo
new file mode 100644
index 000000000000..62c19c50ec7d
--- /dev/null
+++ b/ftp/ftpq/distinfo
@@ -0,0 +1 @@
+MD5 (ftpq-0.06.tar.gz) = c8c941e9e83fdb3135fc25a69961b1ea
diff --git a/ftp/ftpq/pkg-comment b/ftp/ftpq/pkg-comment
new file mode 100644
index 000000000000..2a77235c2bae
--- /dev/null
+++ b/ftp/ftpq/pkg-comment
@@ -0,0 +1 @@
+Upload queue manager for non-permanent connections
diff --git a/ftp/ftpq/pkg-descr b/ftp/ftpq/pkg-descr
new file mode 100644
index 000000000000..72ef51db617e
--- /dev/null
+++ b/ftp/ftpq/pkg-descr
@@ -0,0 +1,8 @@
+ftpq is an ftp upload queue manager. If you live behind
+a dial-up link to the Internet, and regularly upload files
+(e.g. for web sites), ftpq allows you to queue the uploads
+whilst off-line for processing on next connection to the network.
+
+WWW: http://www.tranchant.freeserve.co.uk/ftpq.html
+
+- Will <andrews@technologist.com>
diff --git a/ftp/ftpq/pkg-plist b/ftp/ftpq/pkg-plist
new file mode 100644
index 000000000000..cf60f4a85ec6
--- /dev/null
+++ b/ftp/ftpq/pkg-plist
@@ -0,0 +1 @@
+bin/ftpq