aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2008-04-16 11:24:59 +0800
committerdelphij <delphij@FreeBSD.org>2008-04-16 11:24:59 +0800
commitd7ab125f7cc7eb67f33a461876352c3267fa9c16 (patch)
tree8305059c3597dd8830b336ebe1601f22f6356552 /ftp
parent062b5afbec27feb172bed31ecc1f8e9142f0c51b (diff)
downloadfreebsd-ports-gnome-d7ab125f7cc7eb67f33a461876352c3267fa9c16.tar.gz
freebsd-ports-gnome-d7ab125f7cc7eb67f33a461876352c3267fa9c16.tar.zst
freebsd-ports-gnome-d7ab125f7cc7eb67f33a461876352c3267fa9c16.zip
Update to 1.1; while I'm there, OPTIONize NLS and DEBUG, and
reflect the new home. PR: ports/122802 Approved by: maintainer
Diffstat (limited to 'ftp')
-rw-r--r--ftp/axel/Makefile29
-rw-r--r--ftp/axel/distinfo6
-rw-r--r--ftp/axel/pkg-descr2
-rw-r--r--ftp/axel/pkg-plist4
4 files changed, 30 insertions, 11 deletions
diff --git a/ftp/axel/Makefile b/ftp/axel/Makefile
index 6cbc7a7460b8..ae31bf716289 100644
--- a/ftp/axel/Makefile
+++ b/ftp/axel/Makefile
@@ -7,23 +7,42 @@
#
PORTNAME= axel
-PORTVERSION= 1.0b
-PORTREVISION= 0
+PORTVERSION= 1.1
CATEGORIES= ftp
-MASTER_SITES= http://wilmer.gaast.net/downloads/
+MASTER_SITES= ${MASTER_SITE_GENTOO} \
+ http://alioth.debian.org/frs/download.php/2287/
+MASTER_SITE_SUBDIR= distfiles
MAINTAINER= prudhvikrishna@gmail.com
COMMENT= A download accelerator
-USE_GETTEXT= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MANPREFIX}/man --i18n=1
+OPTIONS= NLS "I18N support" on \
+ DEBUG "Debugging support" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+USE_ICONV= yes
+PLIST_SUB+= NLS=""
+CONFIGURE_ARGS+=--i18n=1
+.else
+PLIST_SUB+= NLS="@comment "
+CONFIGURE_ARGS+=--i18n=0
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--debug=1 --strip=0
+.endif
+
MAN1= axel.1
post-configure:
@${REINPLACE_CMD} -e 's,-O3,${CFLAGS},; s|gcc|${CC}|; \
s|-pthread|${PTHREAD_LIBS}|' ${WRKSRC}/Makefile.settings
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/ftp/axel/distinfo b/ftp/axel/distinfo
index 7593b1014d83..9a2521930dc8 100644
--- a/ftp/axel/distinfo
+++ b/ftp/axel/distinfo
@@ -1,3 +1,3 @@
-MD5 (axel-1.0b.tar.gz) = 679da19b47570f7ddff1e7958d5df97f
-SHA256 (axel-1.0b.tar.gz) = cac515949321fa538deb9ab221d233f722fbc3b82d7f7b7c34d6441cb71d7ad4
-SIZE (axel-1.0b.tar.gz) = 43293
+MD5 (axel-1.1.tar.gz) = 4991b6ed3c2808c6951c8b1e0a276ce7
+SHA256 (axel-1.1.tar.gz) = 398ea22b9805e563c3f703377ae6fedd4e339e6702f0f2af11ac7a8180d3eb43
+SIZE (axel-1.1.tar.gz) = 45650
diff --git a/ftp/axel/pkg-descr b/ftp/axel/pkg-descr
index 69ad58c805b1..05c9514a0e78 100644
--- a/ftp/axel/pkg-descr
+++ b/ftp/axel/pkg-descr
@@ -2,4 +2,4 @@ Axel tries to accelerate downloads by opening more than one connection to a
server (possibly to different servers). Because of its size it might also
be useful as a wget replacement on bootdisks and other small systems.
-WWW: http://wilmer.gaast.net/main.php/axel.html
+WWW: http://axel.alioth.debian.org/
diff --git a/ftp/axel/pkg-plist b/ftp/axel/pkg-plist
index 13d4e2c34284..d7a7df6b7f4a 100644
--- a/ftp/axel/pkg-plist
+++ b/ftp/axel/pkg-plist
@@ -1,4 +1,4 @@
bin/axel
etc/axelrc
-share/locale/de/LC_MESSAGES/axel.mo
-share/locale/nl/LC_MESSAGES/axel.mo
+%%NLS%%share/locale/de/LC_MESSAGES/axel.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/axel.mo