aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-08-21 22:08:06 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-08-21 22:08:06 +0800
commit31445311fce915521f6c1940134b8dc155688036 (patch)
treea29fe29c38d5df1895cfbe84019093fae61a6b42 /ftp
parent3672f197c67f0c967088c7faaced7d9627772e4d (diff)
downloadfreebsd-ports-gnome-31445311fce915521f6c1940134b8dc155688036.tar.gz
freebsd-ports-gnome-31445311fce915521f6c1940134b8dc155688036.tar.zst
freebsd-ports-gnome-31445311fce915521f6c1940134b8dc155688036.zip
- Convert to new perl framework
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile4
-rw-r--r--ftp/p5-SOAP-Transport-FTP/Makefile3
-rw-r--r--ftp/pure-ftpd/Makefile3
3 files changed, 6 insertions, 4 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 8ec9a49d9d5e..0cfb64729204 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -33,9 +33,9 @@ CONFIGURE_ARGS+=--disable-threaded-resolver --disable-werror \
--without-axtls
CONFIGURE_ENV= LOCALBASE="${LOCALBASE}"
GNU_CONFIGURE= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_XZ= yes
-USES= pathfix
+USES= pathfix perl5
.if !defined(BUILDING_HIPHOP)
USE_LDCONFIG= yes
diff --git a/ftp/p5-SOAP-Transport-FTP/Makefile b/ftp/p5-SOAP-Transport-FTP/Makefile
index 19b282213f9c..84adda211fd8 100644
--- a/ftp/p5-SOAP-Transport-FTP/Makefile
+++ b/ftp/p5-SOAP-Transport-FTP/Makefile
@@ -17,7 +17,8 @@ COMMENT= FTP Client support for SOAP::Lite
BUILD_DEPENDS= p5-SOAP-Lite>=0.711:${PORTSDIR}/net/p5-SOAP-Lite
RUN_DEPENDS= p5-SOAP-Lite>=0.711:${PORTSDIR}/net/p5-SOAP-Lite
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= SOAP::Transport::FTP.3
diff --git a/ftp/pure-ftpd/Makefile b/ftp/pure-ftpd/Makefile
index 6a926e5a624c..d1436e3ede94 100644
--- a/ftp/pure-ftpd/Makefile
+++ b/ftp/pure-ftpd/Makefile
@@ -14,8 +14,9 @@ COMMENT= A small, easy to set up, fast, and very secure FTP server
SUB_FILES= pkg-message
SUB_LIST= PAM_DIR=${PAM_DIR} PAM_TARGET=${PAM_TARGET}
USE_BZIP2= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
USE_RC_SUBR= pure-ftpd
+USES= perl5
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-everything \
--with-paranoidmsg \