aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-02 17:22:47 +0800
committeraz <az@FreeBSD.org>2013-09-02 17:22:47 +0800
commit6071aa584d03c4f44a6a0fcc929d60259ab540fc (patch)
tree57ff114ed6c22543eff6f68991fcfc5180976d04 /ftp
parent8f145387b89bd4e2fc168b3f74fc221568a2c94c (diff)
downloadfreebsd-ports-gnome-6071aa584d03c4f44a6a0fcc929d60259ab540fc.tar.gz
freebsd-ports-gnome-6071aa584d03c4f44a6a0fcc929d60259ab540fc.tar.zst
freebsd-ports-gnome-6071aa584d03c4f44a6a0fcc929d60259ab540fc.zip
- convert to the new perl5 framework
Approved by: portmgr (bapt@, blanket)
Diffstat (limited to 'ftp')
-rw-r--r--ftp/ftpcopy/Makefile3
-rw-r--r--ftp/ftpsync/Makefile2
-rw-r--r--ftp/mirror/Makefile2
-rw-r--r--ftp/p5-Net-FTP-Common/Makefile3
-rw-r--r--ftp/p5-Net-FTP-Recursive/Makefile3
5 files changed, 8 insertions, 5 deletions
diff --git a/ftp/ftpcopy/Makefile b/ftp/ftpcopy/Makefile
index dfb9e4584e1d..d46649b982a9 100644
--- a/ftp/ftpcopy/Makefile
+++ b/ftp/ftpcopy/Makefile
@@ -13,7 +13,8 @@ MASTER_SITES= http://www.ohse.de/uwe/ftpcopy/
MAINTAINER= mandree@FreeBSD.org
COMMENT= Command line ftp tools for listing and mirroring
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
WRKSRC= ${WRKDIR}/web/${DISTNAME}
diff --git a/ftp/ftpsync/Makefile b/ftp/ftpsync/Makefile
index ebdd9393feaf..11013a18d92f 100644
--- a/ftp/ftpsync/Makefile
+++ b/ftp/ftpsync/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww
NO_BUILD= yes
USE_BZIP2= yes
-USE_PERL5= yes
+USES= perl5
PLIST_FILES= bin/${PORTNAME}.pl
PORTDOCS= README
diff --git a/ftp/mirror/Makefile b/ftp/mirror/Makefile
index e91da6bf9a0f..b642a5838101 100644
--- a/ftp/mirror/Makefile
+++ b/ftp/mirror/Makefile
@@ -31,7 +31,7 @@ PLIST_FILES= bin/mirror \
PLIST_DIRS= lib/mirror
-USE_PERL5= yes
+USES= perl5
NO_WRKSUBDIR= yes
MAKEFILE= makefile
MAN1= mirror.1 mirror-master.1
diff --git a/ftp/p5-Net-FTP-Common/Makefile b/ftp/p5-Net-FTP-Common/Makefile
index 388a0ba0bf24..258d20b56f48 100644
--- a/ftp/p5-Net-FTP-Common/Makefile
+++ b/ftp/p5-Net-FTP-Common/Makefile
@@ -16,7 +16,8 @@ COMMENT= Perl module to provide simplify common usages of Net::FTP
RUN_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::FTP::Common.3
diff --git a/ftp/p5-Net-FTP-Recursive/Makefile b/ftp/p5-Net-FTP-Recursive/Makefile
index 304302a89e3b..38c9435e7ca8 100644
--- a/ftp/p5-Net-FTP-Recursive/Makefile
+++ b/ftp/p5-Net-FTP-Recursive/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
WRKSRC= ${WRKDIR}/${PORTNAME}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::FTP::Recursive.3