aboutsummaryrefslogtreecommitdiffstats
path: root/games/0ad
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2015-11-27 19:45:28 +0800
committermadpilot <madpilot@FreeBSD.org>2015-11-27 19:45:28 +0800
commit37498b137b73eb49b4a108e6e2385f53a6f6ef87 (patch)
treee3ecb24c4e7283f6a0e5dcce62b7497479ab86da /games/0ad
parent1dabda63a805fea71729b89bb13e9dae6ce094ef (diff)
downloadfreebsd-ports-gnome-37498b137b73eb49b4a108e6e2385f53a6f6ef87.tar.gz
freebsd-ports-gnome-37498b137b73eb49b4a108e6e2385f53a6f6ef87.tar.zst
freebsd-ports-gnome-37498b137b73eb49b4a108e6e2385f53a6f6ef87.zip
- Update to Alpha 19 (0.0.19)
- Add option to choose SDL version to depend on Thanks to the 0ad developers for their suggestions and kind support with the update.
Diffstat (limited to 'games/0ad')
-rw-r--r--games/0ad/Makefile19
-rw-r--r--games/0ad/distinfo8
-rw-r--r--games/0ad/files/patch-build__premake__extern_libs4.lua5
-rw-r--r--games/0ad/files/patch-source_network_NetServer.cpp19
4 files changed, 21 insertions, 30 deletions
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index d63bf7240d5b..6970ab8eb0e6 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= 0ad
-PORTVERSION= 0.0.18
-PORTREVISION= 2
+PORTVERSION= 0.0.19
CATEGORIES= games
MASTER_SITES= SF/zero-ad/releases
DISTFILES= ${PORTNAME}-${PORTVERSION}-alpha-unix-build.tar.xz \
@@ -19,7 +18,6 @@ LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libogg.so:${PORTSDIR}/audio/libogg \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libcurl.so:${PORTSDIR}/ftp/curl \
- libgamin-1.so:${PORTSDIR}/devel/gamin \
libgloox.so:${PORTSDIR}/net-im/gloox \
libminiupnpc.so:${PORTSDIR}/net/miniupnpc \
libnspr4.so:${PORTSDIR}/devel/nspr \
@@ -30,7 +28,6 @@ BUILD_WRKSRC= ${WRKSRC}/build/workspaces/gcc
MAKE_ARGS= config=release
USES= compiler:c++11-lib dos2unix gmake iconv openal:al \
pkgconfig tar:xz
-USE_SDL= sdl
USE_GNOME= libxml2 gtk20
USE_GL= gl
BUNDLE_LIBS= yes
@@ -40,6 +37,18 @@ USE_WX= 2.8+
WX_COMPS= wx:lib
MAKE_ENV+= JOBS=${_MAKE_JOBS}
+OPTIONS_SINGLE= SDL_VERSION
+OPTIONS_SINGLE_SDL_VERSION= SDL SDL2
+OPTIONS_DEFAULT= SDL2
+
+SDL_VERSION_DESC= SDL version
+SDL_DESC= Use SDL 1.2 (deprecated)
+SDL2_DESC= Use SDL 2.0
+
+SDL_USE= SDL=sdl
+SDL_VARS= 0ADSDLARG=--sdl1
+SDL2_USE= SDL=sdl2
+
MANUAL_PACKAGE_BUILD= huge
PORTDATA= *
@@ -65,7 +74,7 @@ post-patch:
${WRKSRC}/build/resources/0ad.sh
pre-build:
- (cd ${WRKSRC}/build/workspaces && ${SETENV} ${MAKE_ENV} ./update-workspaces.sh --with-system-miniupnpc ${SMOPT} --bindir=${PREFIX}/bin --datadir=${DATADIR} --libdir=${PREFIX}/lib/${PORTNAME})
+ (cd ${WRKSRC}/build/workspaces && ${SETENV} ${MAKE_ENV} ./update-workspaces.sh ${0ADSDLARG} --bindir=${PREFIX}/bin --datadir=${DATADIR} --libdir=${PREFIX}/lib/${PORTNAME})
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/binaries/system/pyrogenesis ${STAGEDIR}${PREFIX}/bin
diff --git a/games/0ad/distinfo b/games/0ad/distinfo
index 394c9a1173e9..8753e1fc6602 100644
--- a/games/0ad/distinfo
+++ b/games/0ad/distinfo
@@ -1,4 +1,4 @@
-SHA256 (0ad-0.0.18-alpha-unix-build.tar.xz) = bd2f04d3269ae9af104626827446a89ea4a0dd4859f89539701fd331cbae0397
-SIZE (0ad-0.0.18-alpha-unix-build.tar.xz) = 26179952
-SHA256 (0ad-0.0.18-alpha-unix-data.tar.xz) = b1a4078eb945ac873accb45c831dbe988866e3559d16bea189eb439c2c71ac44
-SIZE (0ad-0.0.18-alpha-unix-data.tar.xz) = 571228108
+SHA256 (0ad-0.0.19-alpha-unix-build.tar.xz) = 2d43262bbcedbfa19eee23b0e78ae20fc9e0b8f4589855fca95d9908c6839bb3
+SIZE (0ad-0.0.19-alpha-unix-build.tar.xz) = 26192128
+SHA256 (0ad-0.0.19-alpha-unix-data.tar.xz) = 9353f554e94adf66d69e33950f7f2515cfe308eca2c0ad381c6f39f1ad378038
+SIZE (0ad-0.0.19-alpha-unix-data.tar.xz) = 573111260
diff --git a/games/0ad/files/patch-build__premake__extern_libs4.lua b/games/0ad/files/patch-build__premake__extern_libs4.lua
index 33280e8f0153..2961665d12ff 100644
--- a/games/0ad/files/patch-build__premake__extern_libs4.lua
+++ b/games/0ad/files/patch-build__premake__extern_libs4.lua
@@ -1,4 +1,4 @@
---- build/premake/extern_libs4.lua.orig 2015-02-20 05:52:18 UTC
+--- build/premake/extern_libs4.lua.orig 2015-11-19 23:47:41 UTC
+++ build/premake/extern_libs4.lua
@@ -237,7 +237,7 @@ extern_lib_defs = {
end
@@ -9,12 +9,13 @@
end
end,
link_settings = function()
-@@ -346,8 +346,6 @@ extern_lib_defs = {
+@@ -347,9 +347,6 @@ extern_lib_defs = {
elseif os.is("macosx") then
add_default_include_paths("iconv")
defines { "LIBICONV_STATIC" }
- elseif os.getversion().description == "FreeBSD" then
- defines { "HAVE_ICONV_CONST" }
+- defines { "ICONV_CONST=const" }
end
end,
link_settings = function()
diff --git a/games/0ad/files/patch-source_network_NetServer.cpp b/games/0ad/files/patch-source_network_NetServer.cpp
deleted file mode 100644
index 0bd7687bd6cb..000000000000
--- a/games/0ad/files/patch-source_network_NetServer.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
---- source/network/NetServer.cpp.orig 2015-01-24 14:46:52 UTC
-+++ source/network/NetServer.cpp
-@@ -228,6 +228,7 @@ void* CNetServerWorker::SetupUPnP(void*)
-
- int ret = 0;
- bool allocatedUrls = false;
-+ int error = 0; // Set this for upnpDiscover
-
- // Try a cached URL first
- if (!rootDescURL.empty() && UPNP_GetIGDFromUrl(rootDescURL.c_str(), &urls, &data, internalIPAddress, sizeof(internalIPAddress)))
-@@ -236,7 +237,7 @@ void* CNetServerWorker::SetupUPnP(void*)
- ret = 1;
- }
- // No cached URL, or it did not respond. Try getting a valid UPnP device for 10 seconds.
-- else if ((devlist = upnpDiscover(10000, 0, 0, 0, 0, 0)) != NULL)
-+ else if ((devlist = upnpDiscover(10000, 0, 0, 0, 0, 0,&error)) != NULL)
- {
- ret = UPNP_GetValidIGD(devlist, &urls, &data, internalIPAddress, sizeof(internalIPAddress));
- allocatedUrls = ret != 0; // urls is allocated on non-zero return values