aboutsummaryrefslogtreecommitdiffstats
path: root/games/2048-qt
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2015-03-26 10:52:14 +0800
committerswills <swills@FreeBSD.org>2015-03-26 10:52:14 +0800
commit6e6037f0caf9e23725fd90d0ca1fc6c1ca08845c (patch)
treeaa113d8367915a80f16b434b893f9888cabafe5f /games/2048-qt
parent8532d35e651cbf655d6e9cc229b3915d8289f225 (diff)
downloadfreebsd-ports-gnome-6e6037f0caf9e23725fd90d0ca1fc6c1ca08845c.tar.gz
freebsd-ports-gnome-6e6037f0caf9e23725fd90d0ca1fc6c1ca08845c.tar.zst
freebsd-ports-gnome-6e6037f0caf9e23725fd90d0ca1fc6c1ca08845c.zip
games/2048-qt: create port
A cross platform clone of 2048, implemented in Qt.
Diffstat (limited to 'games/2048-qt')
-rw-r--r--games/2048-qt/Makefile25
-rw-r--r--games/2048-qt/distinfo2
-rw-r--r--games/2048-qt/pkg-descr3
3 files changed, 30 insertions, 0 deletions
diff --git a/games/2048-qt/Makefile b/games/2048-qt/Makefile
new file mode 100644
index 000000000000..580174308b4c
--- /dev/null
+++ b/games/2048-qt/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= 2048-qt
+PORTVERSION= 0.1.5
+CATEGORIES= games
+MASTER_SITES= GH
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= 2048 game implemented in QT
+
+USE_GITHUB= yes
+GH_ACCOUNT= xiaoyong
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= v${DISTVERSION}
+
+USES= gmake pkgconfig qmake tar:bzip2
+USE_QT5= core gui network widgets qml quick buildtools quickcontrols
+
+WRKSRC= ${WRKDIR}/2048-Qt-${PORTVERSION}
+PLIST_FILES= bin/2048-qt
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/2048-qt ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/games/2048-qt/distinfo b/games/2048-qt/distinfo
new file mode 100644
index 000000000000..057b7474b611
--- /dev/null
+++ b/games/2048-qt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (2048-qt-0.1.5.tar.bz2) = b895ecdbc09127215baf2633b513726cb39e24f22cc309ec390ac9bdae9b224c
+SIZE (2048-qt-0.1.5.tar.bz2) = 1859979
diff --git a/games/2048-qt/pkg-descr b/games/2048-qt/pkg-descr
new file mode 100644
index 000000000000..b3a3058c4fdf
--- /dev/null
+++ b/games/2048-qt/pkg-descr
@@ -0,0 +1,3 @@
+A cross platform clone of 2048, implemented in Qt.
+
+WWW: https://github.com/xiaoyong/2048-Qt