aboutsummaryrefslogtreecommitdiffstats
path: root/games/3dpong
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2001-06-11 07:34:38 +0800
committerdwcjr <dwcjr@FreeBSD.org>2001-06-11 07:34:38 +0800
commit761b493abe5ec3718aeaefe7a346d80be0a8096b (patch)
tree971366f4d1d86aba53edf0dfe35e631a3af17e76 /games/3dpong
parent1eea8efa02ed7f7d934fd485a37ee127506f0b3b (diff)
downloadfreebsd-ports-gnome-761b493abe5ec3718aeaefe7a346d80be0a8096b.tar.gz
freebsd-ports-gnome-761b493abe5ec3718aeaefe7a346d80be0a8096b.tar.zst
freebsd-ports-gnome-761b493abe5ec3718aeaefe7a346d80be0a8096b.zip
Update to new version
Fix patch and add REGEX for chmod PR: 28008 Submitted by: Jeff Palmer <scorpio@drkshdw.org> Reviewed by: will
Diffstat (limited to 'games/3dpong')
-rw-r--r--games/3dpong/Makefile8
-rw-r--r--games/3dpong/distinfo2
-rw-r--r--games/3dpong/files/patch-aa13
3 files changed, 17 insertions, 6 deletions
diff --git a/games/3dpong/Makefile b/games/3dpong/Makefile
index ad62e763de53..b754695e8a15 100644
--- a/games/3dpong/Makefile
+++ b/games/3dpong/Makefile
@@ -6,16 +6,18 @@
#
PORTNAME= 3dpong
-PORTVERSION= 0.3
+PORTVERSION= 0.4
CATEGORIES= games
MASTER_SITES= ftp://ftp.sonic.net/pub/users/nbs/unix/x/3dpong/
-DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
MAKEFILE= makefile
USE_X_PREFIX= yes
-WRKSRC= ${WRKDIR}/3dpong
+
+post-patch:
+ @${PERL} -pi.fbsd -e 's.\tchmod .\t${CHMOD} .g' \
+ ${WRKSRC}/makefile
do-install:
@ ${INSTALL_PROGRAM} ${WRKSRC}/3dpong ${PREFIX}/bin
diff --git a/games/3dpong/distinfo b/games/3dpong/distinfo
index 1e15bb9108c3..cdb29e9024bd 100644
--- a/games/3dpong/distinfo
+++ b/games/3dpong/distinfo
@@ -1 +1 @@
-MD5 (3dpong.0.3.tar.gz) = 456a3acc36ce60557d3bed4ea55fb3a0
+MD5 (3dpong-0.4.tar.gz) = 9f90508b260b43f6cb6514b18fb17acb
diff --git a/games/3dpong/files/patch-aa b/games/3dpong/files/patch-aa
index 74228f0f47da..0f2acf02676f 100644
--- a/games/3dpong/files/patch-aa
+++ b/games/3dpong/files/patch-aa
@@ -1,5 +1,5 @@
---- makefile Sun Mar 15 05:43:34 1998
-+++ /home/andy/tmp/wrk/makefile Sun Jul 11 12:55:29 1999
+--- makefile.orig Sat Mar 14 20:43:34 1998
++++ makefile Sun Jun 10 17:32:36 2001
@@ -11,11 +11,28 @@
# Makefile user-definable variables
@@ -32,6 +32,15 @@
# uncomment for sunos/solaris
#XLIB=-L/usr/openwin/lib -lX11
+@@ -33,7 +50,7 @@
+ # Makefile commands:
+
+ all: 3dpong
+- chmod 755 go handball sounds
++ chmod 755 sounds
+ chmod 644 *.c *.h makefile sounds/*.au *.txt
+
+ clean:
@@ -43,7 +60,7 @@
# Application: