aboutsummaryrefslogtreecommitdiffstats
path: root/games/90secondportraits
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-04-06 01:40:35 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-04-06 01:40:35 +0800
commit70402822c7d71be8bdbcee7ffef06302abf94cb8 (patch)
treeaa5318f8054acb657035354e2136de1b653e3461 /games/90secondportraits
parente4ec9388238afcd62c42bf350d333403abfde174 (diff)
downloadfreebsd-ports-gnome-70402822c7d71be8bdbcee7ffef06302abf94cb8.tar.gz
freebsd-ports-gnome-70402822c7d71be8bdbcee7ffef06302abf94cb8.tar.zst
freebsd-ports-gnome-70402822c7d71be8bdbcee7ffef06302abf94cb8.zip
90 Second Portraits is a silly speed painting game developed for
Ludum Dare 31 Jam competition. Time is money and you have neither! In 90 SECOND PORTRAITS you're paying the bills by speed painting portraits of bypassing customers! You have 90 seconds to paint the customer and his/her prefered background! Your work day ends after 5 customers! WWW: http://tangramgames.dk/games/90secondportraits/
Diffstat (limited to 'games/90secondportraits')
-rw-r--r--games/90secondportraits/Makefile52
-rw-r--r--games/90secondportraits/distinfo7
-rw-r--r--games/90secondportraits/files/90secondportraits.in3
-rw-r--r--games/90secondportraits/pkg-descr10
4 files changed, 72 insertions, 0 deletions
diff --git a/games/90secondportraits/Makefile b/games/90secondportraits/Makefile
new file mode 100644
index 000000000000..2793d7e1f7a1
--- /dev/null
+++ b/games/90secondportraits/Makefile
@@ -0,0 +1,52 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= 90secondportraits
+PORTVERSION= 1.01b
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Silly speed painting game
+
+LICENSE= ZLIB MIT CC-BY-SA-4.0 CC-BY-3.0
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= love:devel/love
+
+USE_GITHUB= yes
+GH_ACCOUNT= SimonLarsen:DEFAULT
+GH_PROJECT= 90-Second-Portraits:DEFAULT
+GH_TUPLE= vrld:hump:537ca76:hump/hump \
+ kikito:middleclass:f670920:middleclass/middleclass
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png
+PORTDOCS= *
+PORTDATA= *
+
+SUB_FILES= ${PORTNAME}
+
+DESKTOP_ENTRIES="${PORTNAME}" \
+ "" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
+ "${PORTNAME}" \
+ "Game;Art;" \
+ ""
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/data/android-icons/drawable-xhdpi/ic_launcher.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.md ${WRKSRC}/*.txt ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/games/90secondportraits/distinfo b/games/90secondportraits/distinfo
new file mode 100644
index 000000000000..14e416a6b293
--- /dev/null
+++ b/games/90secondportraits/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1491397375
+SHA256 (SimonLarsen-90-Second-Portraits-1.01b_GH0.tar.gz) = 01573c76d1438fb667679c076a85ea658efd4847631454edf1a40f6aa4af3953
+SIZE (SimonLarsen-90-Second-Portraits-1.01b_GH0.tar.gz) = 5235757
+SHA256 (vrld-hump-537ca76_GH0.tar.gz) = 78abeb178a75e4ef4dee2b5142c62021796c7b06c7e7ef6854eaeca3f5939875
+SIZE (vrld-hump-537ca76_GH0.tar.gz) = 7057
+SHA256 (kikito-middleclass-f670920_GH0.tar.gz) = afc0cc76fc386ada81630272b2f763ab09830e47d4b91e79e737274c04ba729f
+SIZE (kikito-middleclass-f670920_GH0.tar.gz) = 9126
diff --git a/games/90secondportraits/files/90secondportraits.in b/games/90secondportraits/files/90secondportraits.in
new file mode 100644
index 000000000000..8cfdb3aa0796
--- /dev/null
+++ b/games/90secondportraits/files/90secondportraits.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec %%LOCALBASE%%/bin/love %%DATADIR%% "$@"
diff --git a/games/90secondportraits/pkg-descr b/games/90secondportraits/pkg-descr
new file mode 100644
index 000000000000..8ccff8594aba
--- /dev/null
+++ b/games/90secondportraits/pkg-descr
@@ -0,0 +1,10 @@
+90 Second Portraits is a silly speed painting game developed for
+Ludum Dare 31 Jam competition.
+
+Time is money and you have neither! In 90 SECOND PORTRAITS you're
+paying the bills by speed painting portraits of bypassing customers!
+
+You have 90 seconds to paint the customer and his/her prefered
+background! Your work day ends after 5 customers!
+
+WWW: http://tangramgames.dk/games/90secondportraits/