aboutsummaryrefslogtreecommitdiffstats
path: root/games/HeroesOfMightAndMagic/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2001-03-07 19:35:58 +0800
committerdemon <demon@FreeBSD.org>2001-03-07 19:35:58 +0800
commitebe4077adf98d0d49fdbb8e912e449bd1920c2d2 (patch)
treea0310e834428792721af3afb683a00343d20b873 /games/HeroesOfMightAndMagic/Makefile
parentc71b240cad3a97686fae5bb27af3ee2050e96532 (diff)
downloadfreebsd-ports-gnome-ebe4077adf98d0d49fdbb8e912e449bd1920c2d2.tar.gz
freebsd-ports-gnome-ebe4077adf98d0d49fdbb8e912e449bd1920c2d2.tar.zst
freebsd-ports-gnome-ebe4077adf98d0d49fdbb8e912e449bd1920c2d2.zip
New port: Heroes of Might and Magic III (Linux version).
PR: 25457 Submitted by: Holger Lamm <holger@eit.uni-kl.de>
Diffstat (limited to 'games/HeroesOfMightAndMagic/Makefile')
-rw-r--r--games/HeroesOfMightAndMagic/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/games/HeroesOfMightAndMagic/Makefile b/games/HeroesOfMightAndMagic/Makefile
new file mode 100644
index 000000000000..8f2062165d2c
--- /dev/null
+++ b/games/HeroesOfMightAndMagic/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: HeroesOfMightAndMagic3
+# Date created: 24 Feb 2001
+# Whom: Holger Lamm <holger@eit.uni-kl.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HeroesOfMightAndMagic
+PORTVERSION= 3
+CATEGORIES= games
+MASTER_SITES=
+DISTFILES=
+
+MAINTAINER= holger@eit.uni-kl.de
+
+RUN_DEPENDS= ${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base \
+ ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
+
+PLIST= ${WRKDIR}/PLIST
+IS_INTERACTIVE= yes
+ONLY_FOR_ARCHS= i386
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+NO_CDROM= Software is commercial
+NO_PACKAGE= Software is commercial
+
+GAMESUBDIR= games/Heroes3
+GAMEDIR= ${PREFIX}/${GAMESUBDIR}
+SCRIPTS_ENV+= INSTALL_DATA="${INSTALL_DATA}" PLIST=${PLIST} PKGDIR=${PKGDIR}
+
+do-install:
+ @cd ${.CURDIR} && ${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/do-install
+
+.include <bsd.port.mk>