aboutsummaryrefslogtreecommitdiffstats
path: root/games/abuse_sdl
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-02-14 22:25:09 +0800
committertijl <tijl@FreeBSD.org>2017-02-14 22:25:09 +0800
commit4fe2a9c238e34ebbe01cc2d639f6d8500afaa149 (patch)
treec733c8a110850f79519b2f67095d89cc3e6d7ba0 /games/abuse_sdl
parent864a16fdb3c160493c8cc606df4e0a64845705cf (diff)
downloadfreebsd-ports-gnome-4fe2a9c238e34ebbe01cc2d639f6d8500afaa149.tar.gz
freebsd-ports-gnome-4fe2a9c238e34ebbe01cc2d639f6d8500afaa149.tar.zst
freebsd-ports-gnome-4fe2a9c238e34ebbe01cc2d639f6d8500afaa149.zip
Remove -fPIC and fix the real problem where S_BUTTON_PRESS_SND is sometimes
declared as int and sometimes as long which have a different size and alignment on 64 bit architectures.
Diffstat (limited to 'games/abuse_sdl')
-rw-r--r--games/abuse_sdl/Makefile3
-rw-r--r--games/abuse_sdl/files/patch-src-gui.cpp11
2 files changed, 12 insertions, 2 deletions
diff --git a/games/abuse_sdl/Makefile b/games/abuse_sdl/Makefile
index 3e12bc9be2b3..ffc5f4a63606 100644
--- a/games/abuse_sdl/Makefile
+++ b/games/abuse_sdl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= abuse_sdl
PORTVERSION= 0.8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= GENTOO \
http://abuse.zoy.org/raw-attachment/wiki/download/
@@ -20,7 +20,6 @@ USE_SDL= mixer sdl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-assetdir=${DATADIR} --enable-release
-CFLAGS_aarch64= -fPIC
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/abuse_sdl/files/patch-src-gui.cpp b/games/abuse_sdl/files/patch-src-gui.cpp
new file mode 100644
index 000000000000..2ed6ddd46e2e
--- /dev/null
+++ b/games/abuse_sdl/files/patch-src-gui.cpp
@@ -0,0 +1,11 @@
+--- src/gui.cpp.orig 2011-05-06 09:46:43 UTC
++++ src/gui.cpp
+@@ -117,7 +117,7 @@ void ico_button::draw(int active, image
+
+ }
+
+-extern long S_BUTTON_PRESS_SND;
++extern int S_BUTTON_PRESS_SND;
+ extern int sfx_volume;
+
+ void ico_button::handle_event(event &ev, image *screen, InputManager *im)