aboutsummaryrefslogtreecommitdiffstats
path: root/games/acm
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2015-04-21 03:06:29 +0800
committertijl <tijl@FreeBSD.org>2015-04-21 03:06:29 +0800
commit427785247d2c9559e5acf41ccb52a2a58cd12ba4 (patch)
tree3686bc2aca372d50de8d274ce1e86a1d8116f741 /games/acm
parentb2cc9357b045ceccdc0534c47decc75fefa5b93f (diff)
downloadfreebsd-ports-gnome-427785247d2c9559e5acf41ccb52a2a58cd12ba4.tar.gz
freebsd-ports-gnome-427785247d2c9559e5acf41ccb52a2a58cd12ba4.tar.zst
freebsd-ports-gnome-427785247d2c9559e5acf41ccb52a2a58cd12ba4.zip
- Display a stage-qa warning when ports use PREFIX/var instead of /var
- Add --localstatedir=/var to _LATE_CONFIGURE_ARGS (like --mandir) but not when CONFIGURE_ARGS already sets it. (GNU configure scripts set it to PREFIX/var when PREFIX != /usr.) - Add --localstatedir="${PREFIX}/var" to CONFIGURE_ARGS in some ports so they aren't affected by this change (for now at least). This commit is meant to ensure that new ports don't make the same mistake. - games/acm: the configure script in this port is very old; instead of patching it more, just replace GNU_CONFIGURE with HAS_CONFIGURE. - irc/charybdis: it already used /var but adding --localstatedir=/var changed the behaviour of the configure script; adjust the port to this. PR: 199506 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'games/acm')
-rw-r--r--games/acm/Makefile7
-rw-r--r--games/acm/files/patch-dis-disgen-configure23
2 files changed, 5 insertions, 25 deletions
diff --git a/games/acm/Makefile b/games/acm/Makefile
index 61f9c5f477b5..ff760c871388 100644
--- a/games/acm/Makefile
+++ b/games/acm/Makefile
@@ -14,8 +14,11 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= perl5
-USE_XORG= x11
-GNU_CONFIGURE= yes
+USE_XORG= x11 xext
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --x-includes=${LOCALBASE}/include \
+ --x-libraries=${LOCALBASE}/lib
CONFIGURE_ENV= ac_cv_lib_Xm_XmCreateBulletinBoard=no \
ac_cv_lib_gdbm_dbm_fetch=no
USE_PERL5= build
diff --git a/games/acm/files/patch-dis-disgen-configure b/games/acm/files/patch-dis-disgen-configure
deleted file mode 100644
index 2b52e1983745..000000000000
--- a/games/acm/files/patch-dis-disgen-configure
+++ /dev/null
@@ -1,23 +0,0 @@
---- dis/disgen/configure.orig Mon Jul 16 21:38:36 2007
-+++ dis/disgen/configure Mon Jul 16 21:41:58 2007
-@@ -140,10 +140,20 @@
- EOF
- exit 0 ;;
-
-+ -infodir | --infodir | --infodi | --infod | --info | --inf)
-+ ac_prev=infodir ;;
-+ -infodir=* | --infodir=* | --infodi=* | --infod=* | --info=* | --inf=*)
-+ ;;
-+
- -host | --host | --hos | --ho)
- ac_prev=host ;;
- -host=* | --host=* | --hos=* | --ho=*)
- host="$ac_optarg" ;;
-+
-+ -mandir | --mandir | --mandi | --mand | --man | --ma | --m)
-+ ac_prev=mandir ;;
-+ -mandir=* | --mandir=* | --mandi=* | --mand=* | --man=* | --ma=* | --m=*)
-+ ;;
-
- -nfp | --nfp | --nf)
- # Obsolete; use --without-fp.