aboutsummaryrefslogtreecommitdiffstats
path: root/games/acm
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-06-25 15:48:30 +0800
committermiwi <miwi@FreeBSD.org>2011-06-25 15:48:30 +0800
commit67d5c9192858b2e64c22fc25f23ed58e9fcc4e24 (patch)
tree313fba1fb7997e8902779dfe63998ad88f43c3a4 /games/acm
parenta7807cea676b3d62d865236b14f4991f7dd75f8c (diff)
downloadfreebsd-ports-gnome-67d5c9192858b2e64c22fc25f23ed58e9fcc4e24.tar.gz
freebsd-ports-gnome-67d5c9192858b2e64c22fc25f23ed58e9fcc4e24.tar.zst
freebsd-ports-gnome-67d5c9192858b2e64c22fc25f23ed58e9fcc4e24.zip
- Fix build with CLANG
PR: 158103 Submitted by: Guido Falsi <mad@madpilot.net>
Diffstat (limited to 'games/acm')
-rw-r--r--games/acm/distinfo1
-rw-r--r--games/acm/files/patch-dis-test-disscope.c11
2 files changed, 11 insertions, 1 deletions
diff --git a/games/acm/distinfo b/games/acm/distinfo
index 87e65818c058..c4c478d2b6d3 100644
--- a/games/acm/distinfo
+++ b/games/acm/distinfo
@@ -1,3 +1,2 @@
-MD5 (acm-5.0.tar.gz) = 8d27051a3aa0d85b90f66a86f746e827
SHA256 (acm-5.0.tar.gz) = d5c567681b88a1012548f2a98aa88199e83789518b5303ce8053bb4e38dd5b2b
SIZE (acm-5.0.tar.gz) = 1218154
diff --git a/games/acm/files/patch-dis-test-disscope.c b/games/acm/files/patch-dis-test-disscope.c
new file mode 100644
index 000000000000..52eec9d0df8a
--- /dev/null
+++ b/games/acm/files/patch-dis-test-disscope.c
@@ -0,0 +1,11 @@
+--- dis/test/disscope.c.orig 1998-12-10 23:58:01.000000000 +0100
++++ dis/test/disscope.c 2011-06-21 13:01:46.689444826 +0200
+@@ -172,7 +172,7 @@
+ #endif
+ ++ count;
+ }
+- return;
++ return 0;
+ }
+
+ char *