aboutsummaryrefslogtreecommitdiffstats
path: root/games/adonthell
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-06-05 19:01:34 +0800
committermakc <makc@FreeBSD.org>2010-06-05 19:01:34 +0800
commit03d77d8e4b0a72e9dc6327902a908ed23569fce6 (patch)
tree088bbe2192026963ba133770d50ce5d091c4c47e /games/adonthell
parentfa7379b72bc420166ffa34d504e3eb21c09f86b4 (diff)
downloadfreebsd-ports-gnome-03d77d8e4b0a72e9dc6327902a908ed23569fce6.tar.gz
freebsd-ports-gnome-03d77d8e4b0a72e9dc6327902a908ed23569fce6.tar.zst
freebsd-ports-gnome-03d77d8e4b0a72e9dc6327902a908ed23569fce6.zip
fix typo and use default python version (2.6)
PR: ports/147008 Submitted by: Anonymous <swell.k at gmail.com>
Diffstat (limited to 'games/adonthell')
-rw-r--r--games/adonthell/Makefile8
-rw-r--r--games/adonthell/pkg-plist1
2 files changed, 6 insertions, 3 deletions
diff --git a/games/adonthell/Makefile b/games/adonthell/Makefile
index a135a09da01d..7c4600c06642 100644
--- a/games/adonthell/Makefile
+++ b/games/adonthell/Makefile
@@ -7,7 +7,7 @@
PORTNAME= adonthell
PORTVERSION= 0.3.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SAVANNAH
DISTFILES= ${PORTNAME}-src-${PORTVERSION}${EXTRACT_SUFX} \
@@ -20,7 +20,7 @@ LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
freetype.9:${PORTSDIR}/print/freetype2
USE_SDL= mixer ttf sdl
-USE_PYTHON= -2.5
+USE_PYTHON= yes
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -44,9 +44,11 @@ BROKEN= Does not build on sparc64
post-patch:
@cd ${WRKSRC} && ${REINPLACE_CMD} -e \
's|-g -Wall|$$CFLAGS -Wall|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g' configure
+ s|-lpthread|${PTHREAD_LIBS}|g' configure
@cd ${WRKDIR}/wastesedge-${WEDGE_VERSION} && ${REINPLACE_CMD} -e \
's/test $$adonthell_major_ver -eq 0 .*/true ;/' configure
+ @cd ${WRKDIR}/wastesedge-${WEDGE_VERSION} && ${REINPLACE_CMD} -e \
+ 's/^[[:space:]]*_//' scripts/modules/player_text.py
post-install:
cd ${WRKDIR}/wastesedge-${WEDGE_VERSION} \
diff --git a/games/adonthell/pkg-plist b/games/adonthell/pkg-plist
index 731f29d7b7ef..b81256c87625 100644
--- a/games/adonthell/pkg-plist
+++ b/games/adonthell/pkg-plist
@@ -379,6 +379,7 @@ bin/adonthell-wastesedge
%%DATADIR%%/games/wastesedge/scripts/modules/events.pyc
%%DATADIR%%/games/wastesedge/scripts/modules/intro.pyc
%%DATADIR%%/games/wastesedge/scripts/modules/main_menu.pyc
+%%DATADIR%%/games/wastesedge/scripts/modules/player_text.pyc
%%DATADIR%%/games/wastesedge/scripts/schedules/__init__.pyc
%%DATADIR%%/games/wastesedge/scripts/schedules/audio/__init__.pyc
%%DATADIR%%/games/wastesedge/scripts/schedules/audio/in_game.pyc