aboutsummaryrefslogtreecommitdiffstats
path: root/games/adonthell
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-10-14 16:54:54 +0800
committermarcus <marcus@FreeBSD.org>2006-10-14 16:54:54 +0800
commit0deb7538cc6a5ae90f4e3e4bdbfe6d0ab974aed8 (patch)
tree17937489af4c767844fc63b684ae3e7b31948812 /games/adonthell
parente959473966b963953d63d5f00fae8751f2decf0f (diff)
downloadfreebsd-ports-gnome-0deb7538cc6a5ae90f4e3e4bdbfe6d0ab974aed8.tar.gz
freebsd-ports-gnome-0deb7538cc6a5ae90f4e3e4bdbfe6d0ab974aed8.tar.zst
freebsd-ports-gnome-0deb7538cc6a5ae90f4e3e4bdbfe6d0ab974aed8.zip
Chase the GNOME X11BASE to LOCALBASE move, and fix the build with the
new freetype2 where needed. Submitted by: mezz, ahze, pav, and many others Approved by: portmgr (implicit, kris)
Diffstat (limited to 'games/adonthell')
-rw-r--r--games/adonthell/Makefile4
-rw-r--r--games/adonthell/files/patch-src_SDL_ttf.c20
2 files changed, 22 insertions, 2 deletions
diff --git a/games/adonthell/Makefile b/games/adonthell/Makefile
index 054895e6907e..81a587dc9afa 100644
--- a/games/adonthell/Makefile
+++ b/games/adonthell/Makefile
@@ -3,11 +3,11 @@
# Whom: Miguel Mendez <flynn@energyhq.es.eu.org>
#
# $FreeBSD$
-#
+# $MCom: ports/games/adonthell/Makefile,v 1.1 2006/10/04 20:13:33 ahze Exp $
PORTNAME= adonthell
PORTVERSION= 0.3.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/games/adonthell/files/patch-src_SDL_ttf.c b/games/adonthell/files/patch-src_SDL_ttf.c
new file mode 100644
index 000000000000..0999b7f20ed3
--- /dev/null
+++ b/games/adonthell/files/patch-src_SDL_ttf.c
@@ -0,0 +1,20 @@
+--- src/SDL_ttf.c.orig Wed Oct 4 16:00:53 2006
++++ src/SDL_ttf.c Wed Oct 4 16:12:38 2006
+@@ -43,7 +43,7 @@
+ #include FT_FREETYPE_H
+ #include FT_OUTLINE_H
+ #include FT_TRUETYPE_IDS_H
+-#include FT_INTERNAL_OBJECTS_H
++/* #include FT_INTERNAL_OBJECTS_H */
+
+ #include "SDL.h"
+ #include "SDL_endian.h"
+@@ -270,7 +270,7 @@
+ }
+ memset(stream, 0, sizeof(*stream));
+
+- stream->memory = library->memory;
++ stream->memory = NULL;
+ stream->read = RWread;
+ stream->descriptor.pointer = src;
+ stream->pos = (unsigned long)position;