aboutsummaryrefslogtreecommitdiffstats
path: root/games/agame
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-09-12 05:57:40 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-09-12 05:57:40 +0800
commitf90defc705b5e50614708f42ca97498faaa69314 (patch)
tree378bb23bc57371de6bc523f040e16c9b4e498965 /games/agame
parent004ff8b00abf45c6a99b49329d6e8aa1ddf27c1a (diff)
downloadfreebsd-ports-gnome-f90defc705b5e50614708f42ca97498faaa69314.tar.gz
freebsd-ports-gnome-f90defc705b5e50614708f42ca97498faaa69314.tar.zst
freebsd-ports-gnome-f90defc705b5e50614708f42ca97498faaa69314.zip
- Add DESKTOP_ENTRY to bunch of ports
- Mark some ports MAKE_JOBS_SAFE
Diffstat (limited to 'games/agame')
-rw-r--r--games/agame/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/games/agame/Makefile b/games/agame/Makefile
index 16e15ff4f2ff..589784734f33 100644
--- a/games/agame/Makefile
+++ b/games/agame/Makefile
@@ -9,7 +9,7 @@ PORTNAME= agame
PORTVERSION= 1577
PORTREVISION= 4
CATEGORIES= games
-MASTER_SITES= http://zevv.nl/code/game/ \
+MASTER_SITES= http://zevv.nl/play/code/game/ \
http://critical.ch/distfiles/ \
http://energy.critical.ch/distfiles/
DISTNAME= game-src-${PORTVERSION}
@@ -20,11 +20,19 @@ COMMENT= A simple tetris-like game
USE_SDL= sdl image mixer
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/game
PORTDOCS= README.TXT
+DESKTOP_ENTRIES="game" \
+ "A simple tetris-like game" \
+ "${DATADIR}/img/icon.png" \
+ "game" \
+ "Game;BlocksGame;" \
+ false
+
post-patch:
@${REINPLACE_CMD} -Ee 's,wav/|mp3/|img/,${DATADIR}/&,g' ${WRKSRC}/main.c