aboutsummaryrefslogtreecommitdiffstats
path: root/games/alephone/Makefile
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-08-03 02:33:29 +0800
committermakc <makc@FreeBSD.org>2010-08-03 02:33:29 +0800
commit5cf6fbacae065c32bfc2d04b5707a5a93e582c81 (patch)
treebcfd4dc9247baab6d872cff24f67df68b878464c /games/alephone/Makefile
parent53c7dffc0e442ecdd1c14941e68e51d57161b34d (diff)
downloadfreebsd-ports-gnome-5cf6fbacae065c32bfc2d04b5707a5a93e582c81.tar.gz
freebsd-ports-gnome-5cf6fbacae065c32bfc2d04b5707a5a93e582c81.tar.zst
freebsd-ports-gnome-5cf6fbacae065c32bfc2d04b5707a5a93e582c81.zip
Update to 0.23.2 (20100424)
Pass maintainership to submitter PR: ports/149111 Submitted by: Nico <fiziologus at gmail.com>
Diffstat (limited to 'games/alephone/Makefile')
-rw-r--r--games/alephone/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index d7d215d81ea2..dcabe0de2b3a 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -6,23 +6,22 @@
#
PORTNAME= alephone
-PORTVERSION= 20080913
-PORTREVISION= 4
+PORTVERSION= 20100424
CATEGORIES= games
-MASTER_SITES= SF/marathon/Aleph%20One/2008-09-13
+MASTER_SITES= SF/marathon/Aleph%20One/2010-04-24
DISTNAME= AlephOne-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= fiziologus@gmail.com
COMMENT= The open source version of Bungie's Marathon game
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost-libs \
+ ${LOCALBASE}/include/zzip/lib.h:${PORTSDIR}/devel/zziplib
USE_BZIP2= yes
USE_GL= yes
-USE_GNOME= gnometarget
USE_LUA= 5.1
-USE_SDL= image net sdl sound
+USE_SDL= image ttf net sdl sound
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LUA_INCDIR}" \
LDFLAGS="-L${LOCALBASE}/lib -L${LUA_LIBDIR}"
@@ -31,17 +30,14 @@ DATADIR= ${PREFIX}/share/AlephOne
MAN6= alephone.6
-PORTDOCS= *
-
-.include <bsd.port.pre.mk>
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} README docs/* ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} README ${DOCSDIR}
+ cd ${WRKSRC}/docs && ${INSTALL_DATA} *.html ${DOCSDIR}
.endif
@${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>