aboutsummaryrefslogtreecommitdiffstats
path: root/games/alienblaster
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-10-30 03:52:24 +0800
committerdanilo <danilo@FreeBSD.org>2013-10-30 03:52:24 +0800
commit3c26be0aff1f49e6b65244a3facbd878c7e9b21e (patch)
tree110ea9352256cafaed6719d5876750c8100700c3 /games/alienblaster
parente64b2c6a9264c87aa7c3179c95ddcfba56d84ff2 (diff)
downloadfreebsd-ports-gnome-3c26be0aff1f49e6b65244a3facbd878c7e9b21e.tar.gz
freebsd-ports-gnome-3c26be0aff1f49e6b65244a3facbd878c7e9b21e.tar.zst
freebsd-ports-gnome-3c26be0aff1f49e6b65244a3facbd878c7e9b21e.zip
- Add stage support
- Convert USE_GMAKE to USES
Diffstat (limited to 'games/alienblaster')
-rw-r--r--games/alienblaster/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/games/alienblaster/Makefile b/games/alienblaster/Makefile
index 7cd4740eeed2..28ae2b436273 100644
--- a/games/alienblaster/Makefile
+++ b/games/alienblaster/Makefile
@@ -13,13 +13,12 @@ COMMENT= Alien Blaster
LICENSE= GPLv2
-USE_GMAKE= yes
+USES= gmake
USE_SDL= mixer sdl
REINPLACE_ARGS= -i ''
WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_STAGE= yes
post-patch:
# Fix make command
@${REINPLACE_CMD} -e 's|make|${GMAKE}|g' ${WRKSRC}/${MAKEFILE}
@@ -42,12 +41,12 @@ post-patch:
do-install:
# Executable
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
# Data
- ${MKDIR} ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
.for d in cfg images sound
- ${CP} -R ${WRKSRC}/${d} ${DATADIR}
+ ${CP} -R ${WRKSRC}/${d} ${STAGEDIR}${DATADIR}
.endfor
.include <bsd.port.mk>