aboutsummaryrefslogtreecommitdiffstats
path: root/games/alienwave/Makefile
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2012-12-11 22:37:20 +0800
committerjhale <jhale@FreeBSD.org>2012-12-11 22:37:20 +0800
commit3e23e3e3fd0156713bffaae0e592a6a9d79ec383 (patch)
tree46737bec2cce8ea0b86dcf7f3aa63dd36e97b1d9 /games/alienwave/Makefile
parentb818abecf724503ccdd63fd62485a8745d49e0b9 (diff)
downloadfreebsd-ports-gnome-3e23e3e3fd0156713bffaae0e592a6a9d79ec383.tar.gz
freebsd-ports-gnome-3e23e3e3fd0156713bffaae0e592a6a9d79ec383.tar.zst
freebsd-ports-gnome-3e23e3e3fd0156713bffaae0e592a6a9d79ec383.zip
- Make difficulty selection a little more intuitive
- Simplify DOCS install - Trim header
Diffstat (limited to 'games/alienwave/Makefile')
-rw-r--r--games/alienwave/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/games/alienwave/Makefile b/games/alienwave/Makefile
index 8c7da82ca656..7e84f2e1d961 100644
--- a/games/alienwave/Makefile
+++ b/games/alienwave/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: alienwave
-# Date created: 23 July 2005
-# Whom: Travis Poppe <tlp@liquidx.org>
-#
+# Created by: Travis Poppe <tlp@liquidx.org>
# $FreeBSD$
-#
PORTNAME= alienwave
PORTVERSION= 0.3.0
@@ -24,10 +20,12 @@ PLIST_FILES= bin/alienwave
PORTDOCS= README STORY TO_DO
OPTIONS_DEFINE= RANDOM_LEVELS DOCS
-OPTIONS_RADIO= LEVEL
-OPTIONS_RADIO_LEVEL= LEVEL_EASY LEVEL_HARD
+OPTIONS_DEFAULT=LEVEL_MEDIUM
+OPTIONS_SINGLE= LEVEL
+OPTIONS_SINGLE_LEVEL= LEVEL_EASY LEVEL_MEDIUM LEVEL_HARD
RANDOM_LEVELS_DESC= Enable random waves
LEVEL_EASY_DESC= Killing Xzarna: easy
+LEVEL_MEDIUM_DESC= Killing Xzarna: medium
LEVEL_HARD_DESC= Killing Xzarna: hard
.include <bsd.port.options.mk>
@@ -47,10 +45,8 @@ CFLAGS+= -DRANDOM_LEVELS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/alienwave ${PREFIX}/bin
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-. for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-. endfor
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>