aboutsummaryrefslogtreecommitdiffstats
path: root/games/amphetamine
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-02 02:11:52 +0800
committerkrion <krion@FreeBSD.org>2004-03-02 02:11:52 +0800
commitb45fd7da1742dab3de51854f5cca5993eef8620d (patch)
treeb9970353e8c22d21468e390f8bddcd1f15ab9a10 /games/amphetamine
parentc8d906d3a1da6823f7654841f53fc928a485450c (diff)
downloadfreebsd-ports-gnome-b45fd7da1742dab3de51854f5cca5993eef8620d.tar.gz
freebsd-ports-gnome-b45fd7da1742dab3de51854f5cca5993eef8620d.tar.zst
freebsd-ports-gnome-b45fd7da1742dab3de51854f5cca5993eef8620d.zip
- Fix build on non-i386 arch
PR: ports/63591 Submitted by: Ports Fury
Diffstat (limited to 'games/amphetamine')
-rw-r--r--games/amphetamine/Makefile8
-rw-r--r--games/amphetamine/files/patch-ab24
2 files changed, 15 insertions, 17 deletions
diff --git a/games/amphetamine/Makefile b/games/amphetamine/Makefile
index 55ded5f59115..76411bf975cd 100644
--- a/games/amphetamine/Makefile
+++ b/games/amphetamine/Makefile
@@ -24,14 +24,8 @@ USE_GMAKE= yes
DATAVERSION= 0.8.6
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
-
post-install:
@cd ${WRKDIR}/amph && ${FIND} . | \
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/amph
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/amphetamine/files/patch-ab b/games/amphetamine/files/patch-ab
index a182d87dd5e8..94fa208ff509 100644
--- a/games/amphetamine/files/patch-ab
+++ b/games/amphetamine/files/patch-ab
@@ -1,27 +1,31 @@
---- src/Main.cpp.orig Mon Jun 5 14:34:38 2000
-+++ src/Main.cpp Mon Jun 5 14:34:30 2000
-@@ -1,3 +1,5 @@
+--- src/Main.cpp.orig Sun Mar 24 17:49:09 2002
++++ src/Main.cpp Mon Mar 1 19:51:09 2004
+@@ -1,3 +1,7 @@
++#if defined(__FreeBSD__) && ( defined(__i386__) || defined(__amd64__) )
+#include <floatingpoint.h>
++#endif
+
#include "System.hpp"
#include "Appl.hpp"
#include "Clut.hpp"
-@@ -74,7 +76,7 @@
- my_argc = argc;
+@@ -75,6 +79,9 @@
my_argv = argv;
if (checkCommandLine()) return 0;
--
+
++#if defined(__FreeBSD__) && ( defined(__i386__) || defined(__amd64__) )
+ fpsetmask(fpgetmask() & ~(FP_X_DZ|FP_X_INV));
++#endif
gApplication = new CApplication();
gApplication->InitGraphics();
gApplication->LoadData();
-@@ -82,6 +84,9 @@
- gApplication->UnloadData();
+@@ -83,5 +90,10 @@
gApplication->Quit();
delete gApplication;
-+
+
++#if defined(__FreeBSD__) && ( defined(__i386__) || defined(__amd64__) )
+ fpresetsticky(FP_X_DZ|FP_X_INV);
+ fpsetmask(FP_X_DZ|FP_X_INV);
-
++#endif
++
return 0;
}