aboutsummaryrefslogtreecommitdiffstats
path: root/games/an/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1997-03-04 18:30:13 +0800
committertg <tg@FreeBSD.org>1997-03-04 18:30:13 +0800
commit3ddbd5b854c7ade6142df7b5a88361cc2595cffa (patch)
treeb6c3d4608d4dd355241fef88411f08527a669fb6 /games/an/Makefile
parent5ad854bc791d814998a54966d43ca0b3d53bbb0c (diff)
downloadfreebsd-ports-gnome-3ddbd5b854c7ade6142df7b5a88361cc2595cffa.tar.gz
freebsd-ports-gnome-3ddbd5b854c7ade6142df7b5a88361cc2595cffa.tar.zst
freebsd-ports-gnome-3ddbd5b854c7ade6142df7b5a88361cc2595cffa.zip
Import of an port. an is a fast anagram generator.
Closes PR #2839. Submitted by: Julian Assange <proff@iq.org>
Diffstat (limited to 'games/an/Makefile')
-rw-r--r--games/an/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/games/an/Makefile b/games/an/Makefile
new file mode 100644
index 000000000000..ebdc7273b7e8
--- /dev/null
+++ b/games/an/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: an
+# Version required: 0.93
+# Date created: 28 Feb 1997
+# Whom: proff
+#
+# $Id$
+#
+
+DISTNAME= an-0.93
+CATEGORIES= games
+MASTER_SITES= ftp://suburbia.net/pub/rmj/ \
+ ftp://ftp.suburbia.net/pub/rmj/
+
+MAINTAINER= proff@iq.org
+
+MAKE_ENV+= DEFS=-DDEFDICT=\\\"/usr/share/dict/words\\\"
+ALL_TARGET= with-getopt
+MAN6= an.6
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/an ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/an.6 ${MANPREFIX}/man/man6
+
+.include <bsd.port.mk>