aboutsummaryrefslogtreecommitdiffstats
path: root/games/an
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-18 04:42:03 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-18 04:42:03 +0800
commitb7865fe6bbac314795f5ddfea4b60eacdb1fd521 (patch)
tree8a82a1e61c0a67ae1b7046fc5b1daa252ce38f7a /games/an
parentb835bf4650b138ac33f6ca7ac6888b4756238e4b (diff)
downloadfreebsd-ports-gnome-b7865fe6bbac314795f5ddfea4b60eacdb1fd521.tar.gz
freebsd-ports-gnome-b7865fe6bbac314795f5ddfea4b60eacdb1fd521.tar.zst
freebsd-ports-gnome-b7865fe6bbac314795f5ddfea4b60eacdb1fd521.zip
Support CC/CFLAGS/MAKE properly
PR: 39432 Submitted by: Ports Fury
Diffstat (limited to 'games/an')
-rw-r--r--games/an/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/games/an/Makefile b/games/an/Makefile
index d05a9cc8d4d5..89c086cd6f5d 100644
--- a/games/an/Makefile
+++ b/games/an/Makefile
@@ -7,18 +7,25 @@
PORTNAME= an
PORTVERSION= 0.93
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ftp://suburbia.net/pub/rmj/ \
ftp://ftp.suburbia.net/pub/rmj/
-MAINTAINER= ports@FreeBSD.Org
+MAINTAINER= ports@FreeBSD.org
MAKE_ENV+= DEFS=-DDEFDICT=\\\"/usr/share/dict/words\\\"
ALL_TARGET= with-getopt
MAN6= an.6
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|^CC=|CC?=|g ; \
+ s|^CFLAGS=-O|CFLAGS+=|g ; \
+ s| make| \$$\(MAKE\)|g' ${WRKSRC}/Makefile
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/an ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/an.6 ${MANPREFIX}/man/man6
+ ${INSTALL_PROGRAM} ${WRKSRC}/an ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/an.6 ${MANPREFIX}/man/man6
.include <bsd.port.mk>