aboutsummaryrefslogtreecommitdiffstats
path: root/games/aop/Makefile
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2004-05-05 15:47:27 +0800
committermezz <mezz@FreeBSD.org>2004-05-05 15:47:27 +0800
commita1b51a5f6ff6b640523cf4a13f448d17350a1822 (patch)
treed0994687b9874b5e6031d640a9005050875f14a5 /games/aop/Makefile
parentcf530537c19dd9ebc570c205ba6f77b3670dfd50 (diff)
downloadfreebsd-ports-gnome-a1b51a5f6ff6b640523cf4a13f448d17350a1822.tar.gz
freebsd-ports-gnome-a1b51a5f6ff6b640523cf4a13f448d17350a1822.tar.zst
freebsd-ports-gnome-a1b51a5f6ff6b640523cf4a13f448d17350a1822.zip
Aop (Ambassador Of Pain) is a curses based arcade game for UNIX with only 64
lines of sourcecode. The goal is to drive the hoovercraft (O) trough the level into the 'at' sign (@) and reach as much points as possible by reducing the number of moves and don't losing any time. Lost lifes (0) can easily be picked up by simply drive over them. WWW: http://aop.raffi.at/ PR: ports/65898 Submitted by: Aaron Zauner <az_mail@gmx.at> Approved by: marcus (backup mentor)
Diffstat (limited to 'games/aop/Makefile')
-rw-r--r--games/aop/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/games/aop/Makefile b/games/aop/Makefile
new file mode 100644
index 000000000000..1dde3fdc4273
--- /dev/null
+++ b/games/aop/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: aop
+# Date created: 22. April 2004
+# Whom: Aaron Zauner <az_mail@gmx.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aop
+PORTVERSION= 0.6
+CATEGORIES= games
+MASTER_SITES= http://raffi.at/code/aop/
+
+MAINTAINER= az_mail@gmx.at
+COMMENT= A curses based arcade game with only 64 lines of code
+
+USE_REINPLACE= yes
+DOCS= COPYING README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
+ ${WRKSRC}/Makefile
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for ii in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${ii} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>