aboutsummaryrefslogtreecommitdiffstats
path: root/games/aquaria
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-01-06 13:58:42 +0800
committerjbeich <jbeich@FreeBSD.org>2018-01-06 13:58:42 +0800
commit95672cf44c0701ab30fd965a5dc65c7345670bdd (patch)
tree542fcf66b99cc77a86aec1a7dd92cd2bfc335777 /games/aquaria
parent568e85b0a1af9c21895a577ff3988567bc7e6fdd (diff)
downloadfreebsd-ports-gnome-95672cf44c0701ab30fd965a5dc65c7345670bdd.tar.gz
freebsd-ports-gnome-95672cf44c0701ab30fd965a5dc65c7345670bdd.tar.zst
freebsd-ports-gnome-95672cf44c0701ab30fd965a5dc65c7345670bdd.zip
games/aquaria: unbreak with LLD by default
Linking with LLD currently fails due to preemption of symbols with protected visibility in a shared object: /usr/bin/ld: error: cannot preempt symbol: alGetSourcei >>> defined in /usr/local/lib/libopenal.so >>> referenced by BBGE/FmodOpenALBridge.cpp >>> CMakeFiles/aquaria.dir/BBGE/FmodOpenALBridge.cpp.o:(OggDecoder::decode_loop(OggDecoder*)) /usr/bin/ld: error: cannot preempt symbol: alSourceUnqueueBuffers >>> defined in /usr/local/lib/libopenal.so >>> referenced by BBGE/FmodOpenALBridge.cpp >>> CMakeFiles/aquaria.dir/BBGE/FmodOpenALBridge.cpp.o:(OggDecoder::decode_loop(OggDecoder*)) [...] For now set LLD_UNSAFE=yes so that the port will continue to link with ld.bfd if /usr/bin/ld is lld, until the issue can be addressed (with a change in openal-soft or in lld). Reported by: antoine (via bug 214864)
Diffstat (limited to 'games/aquaria')
-rw-r--r--games/aquaria/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/games/aquaria/Makefile b/games/aquaria/Makefile
index 64e6d9328836..4c880e6fbead 100644
--- a/games/aquaria/Makefile
+++ b/games/aquaria/Makefile
@@ -37,6 +37,7 @@ CMAKE_OFF= AQUARIA_INTERNAL_FREETYPE \
AQUARIA_INTERNAL_TINYXML2 \
AQUARIA_INTERNAL_ZLIB
LDFLAGS+= -Wl,--as-needed # avoid overlinking (vorbis deps)
+LLD_UNSAFE= yes # XXX ports/219089
SUB_FILES= pkg-message
PLIST_FILES= bin/aquaria
PORTDATA= *