aboutsummaryrefslogtreecommitdiffstats
path: root/games/aquaria
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-12-20 02:20:20 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-12-20 02:20:20 +0800
commitc86aad9e33950fc6529257052b55bb6d01a7965d (patch)
tree55ff1570c14967fc7f029655b0f2b20441cef04d /games/aquaria
parentcdff7d456e8a6a834457c30b629fb3040d68b471 (diff)
downloadfreebsd-ports-gnome-c86aad9e33950fc6529257052b55bb6d01a7965d.tar.gz
freebsd-ports-gnome-c86aad9e33950fc6529257052b55bb6d01a7965d.tar.zst
freebsd-ports-gnome-c86aad9e33950fc6529257052b55bb6d01a7965d.zip
Update textproc/tinyxml2 to 6.0.0
- Bump PORTREVISION of dependent ports for shlib change Changes: https://github.com/leethomason/tinyxml2/commits/master
Diffstat (limited to 'games/aquaria')
-rw-r--r--games/aquaria/Makefile2
-rw-r--r--games/aquaria/files/patch-Aquaria-Continuity.cpp11
-rw-r--r--games/aquaria/files/patch-Aquaria-DSQ.cpp11
3 files changed, 23 insertions, 1 deletions
diff --git a/games/aquaria/Makefile b/games/aquaria/Makefile
index a2a26a6c5dae..ad61f79925a7 100644
--- a/games/aquaria/Makefile
+++ b/games/aquaria/Makefile
@@ -4,7 +4,7 @@ PORTNAME= aquaria
DISTVERSIONPREFIX= OSE-v
DISTVERSION= 1.002-22
DISTVERSIONSUFFIX= -g84366ad
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MAINTAINER= jbeich@FreeBSD.org
diff --git a/games/aquaria/files/patch-Aquaria-Continuity.cpp b/games/aquaria/files/patch-Aquaria-Continuity.cpp
new file mode 100644
index 000000000000..e97ff33d76a9
--- /dev/null
+++ b/games/aquaria/files/patch-Aquaria-Continuity.cpp
@@ -0,0 +1,11 @@
+--- Aquaria/Continuity.cpp.orig 2016-06-19 23:56:27 UTC
++++ Aquaria/Continuity.cpp
+@@ -2737,7 +2737,7 @@ void Continuity::loadFileData(int slot,
+ }
+ if (doc.Parse(buf, size) != XML_SUCCESS)
+ {
+- errorLog("Failed to load save data: " + teh_file + " -- Error: " + doc.GetErrorStr1());
++ errorLog("Failed to load save data: " + teh_file + " -- Error: " + doc.ErrorStr());
+ return;
+ }
+ }
diff --git a/games/aquaria/files/patch-Aquaria-DSQ.cpp b/games/aquaria/files/patch-Aquaria-DSQ.cpp
new file mode 100644
index 000000000000..df6e45a890f8
--- /dev/null
+++ b/games/aquaria/files/patch-Aquaria-DSQ.cpp
@@ -0,0 +1,11 @@
+--- Aquaria/DSQ.cpp.orig 2017-12-19 15:08:56 UTC
++++ Aquaria/DSQ.cpp
+@@ -2079,7 +2079,7 @@ void DSQ::loadModsCallback(const std::st
+ if(!Mod::loadModXML(&d, name))
+ {
+ std::ostringstream os;
+- os << "Failed to load mod xml: " << filename << " -- Error: " << d.GetErrorStr1();
++ os << "Failed to load mod xml: " << filename << " -- Error: " << d.ErrorStr();
+ dsq->debugLog(os.str());
+ return;
+ }