aboutsummaryrefslogtreecommitdiffstats
path: root/games/asc/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2003-06-01 21:25:00 +0800
committersobomax <sobomax@FreeBSD.org>2003-06-01 21:25:00 +0800
commitcccfbb0c7253e6e0a9b975e6afae1c18bf1fc09e (patch)
tree9a9795b222dba8414287cfcfd3ce63e7f105bbde /games/asc/Makefile
parent802b07fc4b47733b3ca9920c5306aeeb4ed79033 (diff)
downloadfreebsd-ports-gnome-cccfbb0c7253e6e0a9b975e6afae1c18bf1fc09e.tar.gz
freebsd-ports-gnome-cccfbb0c7253e6e0a9b975e6afae1c18bf1fc09e.tar.zst
freebsd-ports-gnome-cccfbb0c7253e6e0a9b975e6afae1c18bf1fc09e.zip
- Update to 1.13.5.1 and unbroke;
- drop maintainership.
Diffstat (limited to 'games/asc/Makefile')
-rw-r--r--games/asc/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/games/asc/Makefile b/games/asc/Makefile
index 22b6ddf0e7cd..353bf5f88fd9 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= asc
-PORTVERSION= 1.10.2
+PORTVERSION= 1.13.5.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= asc-hq
DISTNAME= ${PORTNAME}-source-${PORTVERSION}
-MAINTAINER= sobomax@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A turn based, multiplayer strategic game with very nice graphics
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
@@ -25,15 +25,13 @@ LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
.endif
-BROKEN= "Configure fails"
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_GMAKE= yes
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
CPPFLAGS="`${SDL_CONFIG} --cflags`" \
LIBS="`${SDL_CONFIG} --libs` -lgnugetopt -lm"
@@ -42,6 +40,8 @@ pre-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@find ${WRKSRC} \( -name "*.cpp" -or -name "*.h" \) | xargs \
${REINPLACE_CMD} -e 's|malloc[.]h|stdlib.h|g'
+ @find ${WRKSRC} -type f -name Makefile.in | xargs \
+ ${REINPLACE_CMD} -e 's|[(]datadir[)]/games|(datadir)|g'
pre-configure:
@${RM} -f ${WRKSRC}/config.cache