aboutsummaryrefslogtreecommitdiffstats
path: root/games/asc/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-04 01:52:46 +0800
committermiwi <miwi@FreeBSD.org>2007-01-04 01:52:46 +0800
commit3ca49111621131700c6473995d2dab479cb7b255 (patch)
treecc7da54b585d97e555dd245fa7740d7fd7d4b703 /games/asc/Makefile
parentb38a55e64fef4c3fb9a26ddfe01824f60d0fa522 (diff)
downloadfreebsd-ports-gnome-3ca49111621131700c6473995d2dab479cb7b255.tar.gz
freebsd-ports-gnome-3ca49111621131700c6473995d2dab479cb7b255.tar.zst
freebsd-ports-gnome-3ca49111621131700c6473995d2dab479cb7b255.zip
- Update to 1.16.4.0
PR: ports/107290 Submitted by: Ying-Chieh Chen <yinjieh@csie.nctu.edu.tw> (maintainer)
Diffstat (limited to 'games/asc/Makefile')
-rw-r--r--games/asc/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/games/asc/Makefile b/games/asc/Makefile
index daa13508bf7c..2fc4f845fdd7 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asc
-PORTVERSION= 1.16.3.0
-PORTREVISION= 1
+PORTVERSION= 1.16.4.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= asc-hq
@@ -26,12 +25,15 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
+USE_GCC= 3.4+
USE_GETOPT_LONG= yes
CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags`" \
CXXFLAGS="-D_UNICODE_BROKEN_" \
LIBS="`${SDL_CONFIG} --libs` -lm"
-CONFIGURE_ARGS= --disable-paraguitest
+CONFIGURE_ARGS= --disable-paraguitest \
+ --prefix=${TARGETDIR} \
+ --mandir=${MANPREFIX}/man
OPTIONS= MUSIC "Install extra music files" off
@@ -63,4 +65,8 @@ pre-build:
post-install:
@${CAT} ${PKGMESSAGE}
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+
.include <bsd.port.post.mk>