aboutsummaryrefslogtreecommitdiffstats
path: root/games/asc
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-10-19 00:53:52 +0800
committersobomax <sobomax@FreeBSD.org>2002-10-19 00:53:52 +0800
commit172db5297c4e99b604928b9ae04048109222bf61 (patch)
treeab1d607cabffde7d71a5d224b4a577c90d37cba2 /games/asc
parent5ab7fbaeb2117cb541ea9b05377ddbf4bedfb441 (diff)
downloadfreebsd-ports-gnome-172db5297c4e99b604928b9ae04048109222bf61.tar.gz
freebsd-ports-gnome-172db5297c4e99b604928b9ae04048109222bf61.tar.zst
freebsd-ports-gnome-172db5297c4e99b604928b9ae04048109222bf61.zip
Fix two patches that I've forgot to update before committing.
Diffstat (limited to 'games/asc')
-rw-r--r--games/asc/Makefile5
-rw-r--r--games/asc/files/patch-configure26
-rw-r--r--games/asc/files/patch-source::gamedlg.cpp8
3 files changed, 30 insertions, 9 deletions
diff --git a/games/asc/Makefile b/games/asc/Makefile
index 53ccdaf6f328..1bcf45a1173a 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -29,15 +29,16 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_GMAKE= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
CPPFLAGS="`${SDL_CONFIG} --cflags`" \
LIBS="`${SDL_CONFIG} --libs` -lgnugetopt -lm"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@find ${WRKSRC} \( -name "*.cpp" -or -name "*.h" \) | xargs \
- ${PERL} -pi -e 's|malloc\.h|stdlib.h|g'
+ ${REINPLACE_CMD} -e 's|malloc[.]h|stdlib.h|g'
pre-configure:
@${RM} -f ${WRKSRC}/config.cache
diff --git a/games/asc/files/patch-configure b/games/asc/files/patch-configure
index 5c9d131284e6..2b933d3d34c4 100644
--- a/games/asc/files/patch-configure
+++ b/games/asc/files/patch-configure
@@ -1,9 +1,29 @@
$FreeBSD$
---- configure.orig Tue Oct 1 15:16:15 2002
-+++ configure Tue Oct 1 15:16:21 2002
-@@ -2992,7 +2992,7 @@
+--- configure.orig Fri Oct 18 19:42:20 2002
++++ configure Fri Oct 18 19:52:51 2002
+@@ -2219,9 +2219,6 @@
+ cat > conftest.$ac_ext <<EOF
+ #line 2221 "configure"
+ #include "confdefs.h"
+-#ifdef __cplusplus
+-extern "C" void exit(int) throw();
+-#endif
+
+ #include <cstdio>
+ #include <cstring>
+@@ -2466,9 +2463,6 @@
+ cat > conftest.$ac_ext <<EOF
+ #line 2468 "configure"
+ #include "confdefs.h"
+-#ifdef __cplusplus
+-extern "C" void exit(int) throw();
+-#endif
+
+ #include "paragui.h"
+ #include "pgapplication.h"
+@@ -2992,7 +2986,7 @@
diff --git a/games/asc/files/patch-source::gamedlg.cpp b/games/asc/files/patch-source::gamedlg.cpp
index 588886467472..3550c33d7ec6 100644
--- a/games/asc/files/patch-source::gamedlg.cpp
+++ b/games/asc/files/patch-source::gamedlg.cpp
@@ -1,13 +1,13 @@
$FreeBSD$
---- source/gamedlg.cpp 2002/10/18 12:57:12 1.2
-+++ source/gamedlg.cpp 2002/10/18 12:57:38
-@@ -3794,7 +3794,7 @@
+--- source/gamedlg.cpp.orig Fri Oct 18 19:39:24 2002
++++ source/gamedlg.cpp Fri Oct 18 19:40:48 2002
+@@ -3788,7 +3791,7 @@
int step = ( target->service[displayed[mp]].maxAmount - target->service[displayed[mp]].minAmount ) / 100;
if ( step == 0 )
step = 1;
-- step = int( pow ( 10, int ( log10 ( (double)step ))));
+- step = int( pow ( 10, int ( log10 ( step ))));
+ step = int( pow ( (double)10, int ( log10 ( (double)step ))));
oldpos[mp] = newpos[mp];