aboutsummaryrefslogtreecommitdiffstats
path: root/games/asc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2015-12-24 07:29:44 +0800
committermiwi <miwi@FreeBSD.org>2015-12-24 07:29:44 +0800
commitd46a6574b707acb195cd696b3039929367cca443 (patch)
tree03cf9fed62d4cf44ccb74a4cfa7b589ac56ecf6c /games/asc
parenta42100e8ba1c75b33d712c967926343405b47e59 (diff)
downloadfreebsd-ports-gnome-d46a6574b707acb195cd696b3039929367cca443.tar.gz
freebsd-ports-gnome-d46a6574b707acb195cd696b3039929367cca443.tar.zst
freebsd-ports-gnome-d46a6574b707acb195cd696b3039929367cca443.zip
- Update to 2.6.0.0
PR: 205205 Submitted by: ports fury Approved by: mat (mentor) Differential Revision: D4635
Diffstat (limited to 'games/asc')
-rw-r--r--games/asc/Makefile47
-rw-r--r--games/asc/distinfo4
2 files changed, 22 insertions, 29 deletions
diff --git a/games/asc/Makefile b/games/asc/Makefile
index 609f0b0bf62d..beb9332e949e 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= asc
-PORTVERSION= 2.6.0.0
-PORTREVISION= 6
+PORTVERSION= 2.6.1.0
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}-hq/ASC%20Source/${PORTVERSION:R} \
http://www.asc-hq.org/music/:music
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${ASC_MUSICS:S/$/:music/}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -21,23 +20,18 @@ BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
RUN_DEPENDS:= ${BUILD_DEPENDS}
LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
libboost_regex.so:${PORTSDIR}/devel/boost-libs \
- libsigc-1.2.so:${PORTSDIR}/devel/libsigc++12 \
+ libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
libexpat.so:${PORTSDIR}/textproc/expat2 \
libloki.so:${PORTSDIR}/devel/loki
-OPTIONS_DEFINE= MUSIC XVID
-MUSIC_DESC= Install extra music files
-
-USES= compiler:c++11-lib gmake libtool lua:51 perl5 pkgconfig tar:bzip2
+USES= compiler:c++11-lib gmake libtool lua perl5 pkgconfig tar:bzip2
USE_CXXSTD= c++11
USE_SDL= image mixer sound sdl
USE_WX= 3.0
-WX_UNICODE= yes
WX_CONF_ARGS= absolute
USE_PERL5= build
GNU_CONFIGURE= yes
-CFLAGS+= -D_UNICODE_BROKEN_
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -51,28 +45,25 @@ PLIST_FILES= bin/asc \
man/man6/asc_mapedit.6.gz \
man/man6/asc_mount.6.gz \
man/man6/asc_weaponguide.6.gz \
- share/appdata/asc.appdata.xml
-PORTDATA= *
+ share/appdata/asc.appdata.xml \
+ ${DATADIR}/asc2_dlg.zip \
+ ${DATADIR}/main.ascdat
DESKTOP_ENTRIES="Advanced Strategic Command" "Turn based strategic game" "" \
"${PORTNAME}" "" ""
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MXVID}
-LIB_DEPENDS+= libxvidcore.so:${PORTSDIR}/multimedia/xvid
-.else
-CONFIGURE_ENV+= ac_cv_lib_xvidcore_xvid_encore=no
-.endif
+OPTIONS_DEFINE= MUSIC XVID
-.if ${PORT_OPTIONS:MMUSIC}
-ASC_MUSICS= frontiers.ogg time_to_strike.ogg machine_wars.ogg
+MUSIC_DESC= Install extra music files
+MUSIC_DISTFILES= ${ASC_MUSICS:S,$,:music,}
+MUSIC_PLIST_FILES= ${ASC_MUSICS:S,^,%%DATADIR%%/music/,}
+XVID_LIB_DEPENDS= libxvidcore.so:${PORTSDIR}/multimedia/xvid
+XVID_CONFIGURE_ENV_OFF= ac_cv_lib_xvidcore_xvid_encore=no
+ASC_MUSICS= frontiers.ogg time_to_strike.ogg machine_wars.ogg
-post-extract:
-.for i in ${ASC_MUSICS}
- @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${i} ${WRKSRC}/data/music
-.endfor
-.endif
+post-extract-MUSIC-on:
+ @(cd ${DISTDIR}/${DIST_SUBDIR} && ${CP} ${ASC_MUSICS} \
+ ${WRKSRC}/data/music)
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" -print0 | ${XARGS} -0 \
@@ -80,9 +71,11 @@ post-patch:
's|/games/|/|g'
@${REINPLACE_CMD} -e \
's|/games/|/|g ; \
- s|lua >=|lua-5.1 >=|g ; \
+ s|lua >= 5.1 |lua-${LUA_VER}|g ;\
/if test/s|==|=|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
's|? 0 :|? (void)0 :|' ${WRKSRC}/source/errors.h
+ @${REINPLACE_CMD} -e \
+ 's|tAttackH|AttackH|' ${WRKSRC}/source/actions/vehicleattack.h
.include <bsd.port.mk>
diff --git a/games/asc/distinfo b/games/asc/distinfo
index 19d10976de89..f3f5b1d8de85 100644
--- a/games/asc/distinfo
+++ b/games/asc/distinfo
@@ -1,5 +1,5 @@
-SHA256 (asc/asc-2.6.0.0.tar.bz2) = e59caa549dc8d8a321211f60652cc809cbbf37d000ee85af790e676d9656cbbb
-SIZE (asc/asc-2.6.0.0.tar.bz2) = 42280527
+SHA256 (asc/asc-2.6.1.0.tar.bz2) = 9a1e58e73ba8fdf5d5ac85cdb66804bf688dce2940a8a9c26796de6b6d4f8ddb
+SIZE (asc/asc-2.6.1.0.tar.bz2) = 42569531
SHA256 (asc/frontiers.ogg) = eabc9b07d1db07626fa817a30dad23b11aada059e32c08914d2d0cf1d58c7fff
SIZE (asc/frontiers.ogg) = 4691844
SHA256 (asc/time_to_strike.ogg) = 0334a027b8a45a5df88e1e3e7db9cace2def02396fbcc794d157289e41c9ad05