aboutsummaryrefslogtreecommitdiffstats
path: root/games/assaultcube/Makefile
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-10-21 10:00:57 +0800
committeralepulver <alepulver@FreeBSD.org>2007-10-21 10:00:57 +0800
commit28212b6d954c49b695bd7a90a463e47f40170166 (patch)
treeb6279c32211a3ea3f1a0c05c5142ba34888ee5f4 /games/assaultcube/Makefile
parent155b53fbda8d87043f55b60d77098668a2f14d71 (diff)
downloadfreebsd-ports-gnome-28212b6d954c49b695bd7a90a463e47f40170166.tar.gz
freebsd-ports-gnome-28212b6d954c49b695bd7a90a463e47f40170166.tar.zst
freebsd-ports-gnome-28212b6d954c49b695bd7a90a463e47f40170166.zip
- Update correct port: the new assaultcube, instead of the old actioncube.
PR: ports/116746 Reported by: ale
Diffstat (limited to 'games/assaultcube/Makefile')
-rw-r--r--games/assaultcube/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/games/assaultcube/Makefile b/games/assaultcube/Makefile
index 1b3ea4d4bb2d..bc0ed7e81ff2 100644
--- a/games/assaultcube/Makefile
+++ b/games/assaultcube/Makefile
@@ -5,12 +5,11 @@
# $FreeBSD$
#
-PORTNAME= actioncube
-PORTVERSION= 0.92
-PORTREVISION= 1
+PORTNAME= assaultcube
+PORTVERSION= 0.93
CATEGORIES= games
MASTER_SITES= SF/actiongame
-DISTNAME= ActionCube_v${PORTVERSION}
+DISTNAME= AssaultCube_v${PORTVERSION}
MAINTAINER= alepulver@FreeBSD.org
COMMENT= Total conversion of the FPS game called Cube
@@ -19,7 +18,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
ALL_TARGET= libenet
-WRKSRC= ${WRKDIR}/ActionCube
+WRKSRC= ${WRKDIR}/${DISTNAME:C/_v.*//}
CONFIGURE_WRKSRC= ${WRKSRC}/source/enet
BUILD_WRKSRC= ${WRKSRC}/source/src
@@ -56,14 +55,14 @@ PLIST_SUB+= DEDICATED="@comment "
.endif
.if defined(WITHOUT_OPTIMIZED_CFLAGS)
-MAKE_ENV+= CXXOPTFLAGS=""
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(CXXOPTFLAGS)||' ${WRKSRC}/source/src/Makefile
.endif
do-install:
.for f in ${ACUBE_BIN}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}_${f} ${PREFIX}/bin
.endfor
- ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
.for f in ${ACUBE_BIN}
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/ac_${f} \
${PREFIX}/libexec/${PORTNAME}_${f}