aboutsummaryrefslogtreecommitdiffstats
path: root/games/atr3d
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-01-14 02:26:51 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-01-14 02:26:51 +0800
commite155ee1903f2f3e23a4bbe53e41815044ba5a8ce (patch)
treefe43d3b03620738d1cd25df8786cfbb866076cc8 /games/atr3d
parent4a54727b56ada369f78ba4b0fb1b7334fad5cc0a (diff)
downloadfreebsd-ports-gnome-e155ee1903f2f3e23a4bbe53e41815044ba5a8ce.tar.gz
freebsd-ports-gnome-e155ee1903f2f3e23a4bbe53e41815044ba5a8ce.tar.zst
freebsd-ports-gnome-e155ee1903f2f3e23a4bbe53e41815044ba5a8ce.zip
- Add LICENSE
- Switch to USES=autoreconf - Remove unused variables - Use new OPTIONS features - Drop @dirrm* from plist
Diffstat (limited to 'games/atr3d')
-rw-r--r--games/atr3d/Makefile33
-rw-r--r--games/atr3d/pkg-plist5
2 files changed, 9 insertions, 29 deletions
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index 37694f80c20e..ff5b73b0ea2d 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -7,49 +7,34 @@ PORTREVISION= 17
CATEGORIES= games
MASTER_SITES= http://rodrigo.osorio.free.fr/freebsd/distfiles/
DISTNAME= ${PORTNAME}_source_${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= 3D asteroids-like multiplayer game
-OPTIONS_DEFINE= OPENAL
-OPTIONS_DEFAULT=OPENAL
-
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= gmake perl5
+USES= autoreconf gmake perl5 tar:tgz
USE_GL= glut glu
USE_XORG= xmu xi x11
USE_PERL5= build
GNU_CONFIGURE= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
-USE_AUTOTOOLS= automake autoconf
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= OPENAL
+OPTIONS_DEFAULT=OPENAL
-.if ${PORT_OPTIONS:MOPENAL}
-USES+= openal:alut
-CONFIGURE_ARGS+= --enable-sound
-.else
-CONFIGURE_ARGS+= --disable-sound
-.endif
+OPENAL_USES= openal:alut
+OPENAL_CONFIGURE_ENABLE= sound
pre-patch:
- @${REINPLACE_CMD} -i '' -e 's|^aclocal|${ACLOCAL}|' \
- -e 's|^autoconf|${AUTOCONF}|' \
- -e 's|^automake|${AUTOMAKE}|' \
- ${WRKSRC}/autogen.sh
@${REINPLACE_CMD} -e 's|-lopenal|& -lalut|' ${WRKSRC}/Makefile.am
post-patch:
@${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/Makefile.am
-pre-configure:
- cd ${WRKSRC}; ${SH} autogen.sh
-
.include <bsd.port.mk>
diff --git a/games/atr3d/pkg-plist b/games/atr3d/pkg-plist
index c819113f7b4a..d529ad3aa2cd 100644
--- a/games/atr3d/pkg-plist
+++ b/games/atr3d/pkg-plist
@@ -33,8 +33,3 @@ bin/atr3d
%%DATADIR%%/sounds/8.wav
%%DATADIR%%/sounds/9.wav
%%DATADIR%%/textures/explosion.rgb
-@dirrm %%DATADIR%%/conf
-@dirrm %%DATADIR%%/models
-@dirrm %%DATADIR%%/sounds
-@dirrm %%DATADIR%%/textures
-@dirrm %%DATADIR%%