aboutsummaryrefslogtreecommitdiffstats
path: root/games/baduki
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-01-28 20:49:58 +0800
committeredwin <edwin@FreeBSD.org>2003-01-28 20:49:58 +0800
commita76cb7478fc1df14f9b7f0af92cc86e2d27dfe84 (patch)
treec0196cf62159f61f8cb7f1d12b41d5565905a3bc /games/baduki
parentda6c36ad0b935142011d110ece8d7137592c7035 (diff)
downloadfreebsd-ports-gnome-a76cb7478fc1df14f9b7f0af92cc86e2d27dfe84.tar.gz
freebsd-ports-gnome-a76cb7478fc1df14f9b7f0af92cc86e2d27dfe84.tar.zst
freebsd-ports-gnome-a76cb7478fc1df14f9b7f0af92cc86e2d27dfe84.zip
MAINTAINER: cure games/baduki of its perl addiction
PR: ports/47382 Submitted by: Steve Coltrin <spcoltri@omcl.org>
Diffstat (limited to 'games/baduki')
-rw-r--r--games/baduki/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/baduki/Makefile b/games/baduki/Makefile
index c4357c8566a5..70e6b442d169 100644
--- a/games/baduki/Makefile
+++ b/games/baduki/Makefile
@@ -16,14 +16,15 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOMENG= yes
USE_GNOME= gtk12
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
- s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
+ s|\$$(top_builddir)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
.include <bsd.port.mk>