aboutsummaryrefslogtreecommitdiffstats
path: root/games/black-box
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-12-11 23:57:28 +0800
committernemysis <nemysis@FreeBSD.org>2013-12-11 23:57:28 +0800
commita4a7d7feb3cb179c55aad348bd04b999d1190a5a (patch)
treedc213890fc830caf6a24f3aafc92770eab15742c /games/black-box
parent8c88c229455d63fda56633d508f7cde90ac76878 (diff)
downloadfreebsd-ports-gnome-a4a7d7feb3cb179c55aad348bd04b999d1190a5a.tar.gz
freebsd-ports-gnome-a4a7d7feb3cb179c55aad348bd04b999d1190a5a.tar.zst
freebsd-ports-gnome-a4a7d7feb3cb179c55aad348bd04b999d1190a5a.zip
- Change Makefile header
- Change master sites - Change maintainer email to @FreeBSD.org - Add DOCS Option amd remove INSTALL - Support STAGEDIR - Change desktop entry - Break lines around 80 characters Approved by: pawel / wg (mentors, implicit)
Diffstat (limited to 'games/black-box')
-rw-r--r--games/black-box/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/games/black-box/Makefile b/games/black-box/Makefile
index a8528fe693da..73196ee1f76e 100644
--- a/games/black-box/Makefile
+++ b/games/black-box/Makefile
@@ -1,4 +1,4 @@
-# Created by: nemysis@gmx.ch
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= black-box
@@ -6,34 +6,32 @@ PORTVERSION= 1.4.8
PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.linux-games.com/black-box/ \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}.png:icons
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= Shoot in and watch where the shot leaves the box
LICENSE= GPLv2
-GNU_CONFIGURE= yes
USE_SDL= sdl image mixer
+GNU_CONFIGURE= yes
-PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README
+PORTDOCS= AUTHORS ChangeLog NEWS README
-DESKTOP_ENTRIES="Black-Box" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Game;ArcadeGame;" ${FALSE}
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+DESKTOP_ENTRIES="Black-Box" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
post-install:
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>