aboutsummaryrefslogtreecommitdiffstats
path: root/games/bnetd
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2000-07-05 20:37:06 +0800
committertg <tg@FreeBSD.org>2000-07-05 20:37:06 +0800
commit3a84881f168162a487490bbbd275ca05b7f5560d (patch)
treee888acd7e17d635c1f902fccb1eefdf89f15641a /games/bnetd
parent83513fef56c1c9996eb040a93488ed7837fac927 (diff)
downloadfreebsd-ports-gnome-3a84881f168162a487490bbbd275ca05b7f5560d.tar.gz
freebsd-ports-gnome-3a84881f168162a487490bbbd275ca05b7f5560d.tar.zst
freebsd-ports-gnome-3a84881f168162a487490bbbd275ca05b7f5560d.zip
As threatened on freebsd-ports: all startup scripts know about the two
options `start' and `stop' now (unless I have forgotten any). This allows us to call the scripts from /etc/rc.shutdown with the correct option. The (42 or so) ports that already DTRT before are unchanged.
Diffstat (limited to 'games/bnetd')
-rw-r--r--games/bnetd/Makefile5
-rw-r--r--games/bnetd/files/bnetd.sh20
2 files changed, 22 insertions, 3 deletions
diff --git a/games/bnetd/Makefile b/games/bnetd/Makefile
index a73fc13a43a6..8d90c2eb3236 100644
--- a/games/bnetd/Makefile
+++ b/games/bnetd/Makefile
@@ -32,9 +32,8 @@ do-install:
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/bnetd.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/bnetd.sh startup file."; \
- ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/bnetd.sh; \
- ${ECHO} "cd ${PREFIX}; [ -x sbin/bnetd -a -f bnetd/conf/bnetd.conf ] && sbin/bnetd -c bnetd/conf/bnetd.conf > /dev/null && ${ECHO} -n ' bnetd'" >> ${PREFIX}/etc/rc.d/bnetd.sh; \
- ${CHMOD} 751 ${PREFIX}/etc/rc.d/bnetd.sh; \
+ ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/bnetd.sh \
+ ${PREFIX}/etc/rc.d/bnetd.sh; \
fi
.include <bsd.port.mk>
diff --git a/games/bnetd/files/bnetd.sh b/games/bnetd/files/bnetd.sh
new file mode 100644
index 000000000000..fe9cf99c7164
--- /dev/null
+++ b/games/bnetd/files/bnetd.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ cd ${PREFIX}; [ -x sbin/bnetd -a -f bnetd/conf/bnetd.conf ] && sbin/bnetd -c bnetd/conf/bnetd.conf > /dev/null && echo -n ' bnetd'
+ ;;
+stop)
+ killall bnetd && echo -n ' bnetd'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0