aboutsummaryrefslogtreecommitdiffstats
path: root/games/bombermaze
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-11 23:31:46 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-11 23:31:46 +0800
commit56dc32204bad654a33f748f15525ae2478dda76c (patch)
tree3937ab3f9e452769dfc3da529bc9b040b4183bc3 /games/bombermaze
parent169df2917434face98111a403e13db5d03f78444 (diff)
downloadfreebsd-ports-gnome-56dc32204bad654a33f748f15525ae2478dda76c.tar.gz
freebsd-ports-gnome-56dc32204bad654a33f748f15525ae2478dda76c.tar.zst
freebsd-ports-gnome-56dc32204bad654a33f748f15525ae2478dda76c.zip
Use USE_REINPLACE.
Diffstat (limited to 'games/bombermaze')
-rw-r--r--games/bombermaze/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/games/bombermaze/Makefile b/games/bombermaze/Makefile
index 61135f12babc..cb8a2ef933d4 100644
--- a/games/bombermaze/Makefile
+++ b/games/bombermaze/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= gnome@FreeBSD.org
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
+USE_REINPLACE= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -23,10 +24,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CFLAGS+= -fpermissive
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
+ s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>