aboutsummaryrefslogtreecommitdiffstats
path: root/games/bombherman/Makefile
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-02-21 02:05:17 +0800
committermakc <makc@FreeBSD.org>2013-02-21 02:05:17 +0800
commite887887746951ea4beb864c0bcd6a75197954aa0 (patch)
tree566afdb320026f8c71a5d5b2efba04060a0f86b2 /games/bombherman/Makefile
parent5fe400aadf250255a9416069160e03b9acdebb5c (diff)
downloadfreebsd-ports-gnome-e887887746951ea4beb864c0bcd6a75197954aa0.tar.gz
freebsd-ports-gnome-e887887746951ea4beb864c0bcd6a75197954aa0.tar.zst
freebsd-ports-gnome-e887887746951ea4beb864c0bcd6a75197954aa0.zip
- Update icons
- Set PORTSCOUT PR: ports/173456 Submitted by: nemysis (maintainer)
Diffstat (limited to 'games/bombherman/Makefile')
-rw-r--r--games/bombherman/Makefile29
1 files changed, 18 insertions, 11 deletions
diff --git a/games/bombherman/Makefile b/games/bombherman/Makefile
index 6a5f37ded060..968909c98a78 100644
--- a/games/bombherman/Makefile
+++ b/games/bombherman/Makefile
@@ -1,23 +1,21 @@
-# Created by: nemysis@gmx.ch
-#
+# Created by: nemysis@gmx.ch
# $FreeBSD$
PORTNAME= bomb-her-man
PORTVERSION= 0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= GH \
SF/nemysisfreebsdp/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
- ${PORTNAME}_icons.tar.gz:icons
+ ${PORTNAME}_icons${EXTRACT_SUFX}:icons
MAINTAINER= nemysis@gmx.ch
COMMENT= Bomberman clone written in C++
LICENSE= GPLv3
-BUILD_DEPENDS= automake:${PORTSDIR}/devel/automake \
- p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
USE_GITHUB= yes
@@ -29,7 +27,7 @@ GH_COMMIT= 8f5aa22
USE_SDL= sdl image mixer ttf
USE_GNOME= intltool librsvg2
GNU_CONFIGURE= yes
-AUTOMAKE_ARGS= --add-missing
+USE_AUTOTOOLS= automake:env
USE_GMAKE= yes
ALL_TARGET= # empty
MAKE_JOBS_SAFE= yes
@@ -39,12 +37,16 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= AUTHORS ChangeLog NEWS README
-DESKTOP_ENTRIES="Bomb-her-man" "Bomberman clone" \
- "${PREFIX}/share/pixmaps/${PORTNAME}_48.png" \
+INSTALLS_ICONS= yes
+ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
+
+DESKTOP_ENTRIES="Bomb-her-man" "Bomberman clone" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" false
OPTIONS_DEFINE= NLS
-OPTIONS_DEFAULT= NLS
+
+# Wrong versioning upstream
+PORTSCOUT= ignore:1
.include <bsd.port.options.mk>
@@ -65,7 +67,12 @@ pre-configure:
.endif
post-install:
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}*.png ${PREFIX}/share/pixmaps
+.for s in ${ICON_SIZES}
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
+ ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}