aboutsummaryrefslogtreecommitdiffstats
path: root/games/bomns
diff options
context:
space:
mode:
authorlesi <lesi@FreeBSD.org>2005-07-23 07:38:08 +0800
committerlesi <lesi@FreeBSD.org>2005-07-23 07:38:08 +0800
commit48fdc360a1517ef90c9ca5d74172833fc379b778 (patch)
tree2ed381bb2679cb489183fc923a7201c6a10edd4c /games/bomns
parenta7ba8853c5db48af4c10188b00a71fd99d33fd29 (diff)
downloadfreebsd-ports-gnome-48fdc360a1517ef90c9ca5d74172833fc379b778.tar.gz
freebsd-ports-gnome-48fdc360a1517ef90c9ca5d74172833fc379b778.tar.zst
freebsd-ports-gnome-48fdc360a1517ef90c9ca5d74172833fc379b778.zip
Bomns is by far the greatest game to ever grace the face of the earth. It has
a HUGE cult following (largely based in Asheville, NC) because of its immense fun factor and its unique ability to increase your sex appeal and significantly lengthen your life. Originally conceived by Charles Lindsay, it has taken many forms since the first "Bomns". PR: ports/83922 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Diffstat (limited to 'games/bomns')
-rw-r--r--games/bomns/Makefile68
-rw-r--r--games/bomns/distinfo2
-rw-r--r--games/bomns/pkg-descr10
-rw-r--r--games/bomns/pkg-plist31
4 files changed, 111 insertions, 0 deletions
diff --git a/games/bomns/Makefile b/games/bomns/Makefile
new file mode 100644
index 000000000000..a0d7a138d3a9
--- /dev/null
+++ b/games/bomns/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: bomns
+# Date created: 22 Jul 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bomns
+PORTVERSION= 0.99.1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= greenridge
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= The best old-school deathmatch game EVER (only for two players)
+
+USE_BZIP2= yes
+USE_SDL= mixer sdl
+WANT_GNOME= yes
+USE_REINPLACE= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags`" \
+ LDFLAGS="`${SDL_CONFIG} --libs`"
+CONFIGURE_ARGS= --program-transform-name=
+
+OPTIONS= EDITOR "Enable building of the map editor" on \
+ LAUNCHER "Enable building of the GTK2 launcher" on \
+ OPTIMIZED_CFLAGS "Enable compilation optimizations" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_EDITOR)
+PLIST_SUB+= EDITOR=""
+.else
+CONFIGURE_ARGS+= --disable-editor
+PLIST_SUB+= EDITOR="@comment "
+.endif
+
+.if defined(WITH_LAUNCHER)
+USE_GNOME= gtk20
+PLIST_SUB+= LAUNCHER=""
+.else
+CONFIGURE_ARGS+= --disable-launcher2
+PLIST_SUB+= LAUNCHER="@comment "
+.endif
+
+post-patch:
+# Fix SDL include statement
+.for f in *.cpp *.h
+ @${FIND} ${WRKSRC}/src -type f -name ${f} -print0 | \
+ ${XARGS} -0 \
+ ${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|'
+.endfor
+
+# Remove -lSDL linker flag
+.for f in Makefile.am Makefile.in
+ @${FIND} ${WRKSRC}/src -type f -name ${f} -print0 | \
+ ${XARGS} -0 \
+ ${REINPLACE_CMD} -e 's|-lSDL || ; s|-lSDL$$|| ; s|-lpthread||'
+.endfor
+
+# Enable/disable compilation optimizations
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${REINPLACE_CMD} -e 's|-O2||' ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/bomns/distinfo b/games/bomns/distinfo
new file mode 100644
index 000000000000..3cca8a03159c
--- /dev/null
+++ b/games/bomns/distinfo
@@ -0,0 +1,2 @@
+MD5 (bomns-0.99.1.tar.bz2) = 08bca3c88209a36221966678d5a7e4bc
+SIZE (bomns-0.99.1.tar.bz2) = 839812
diff --git a/games/bomns/pkg-descr b/games/bomns/pkg-descr
new file mode 100644
index 000000000000..3cb1e78eb6c4
--- /dev/null
+++ b/games/bomns/pkg-descr
@@ -0,0 +1,10 @@
+Bomns is by far the greatest game to ever grace the face of the earth. It has
+a HUGE cult following (largely based in Asheville, NC) because of its immense
+fun factor and its unique ability to increase your sex appeal and
+significantly lengthen your life. Originally conceived by Charles Lindsay, it
+has taken many forms since the first "Bomns".
+
+WWW: http://greenridge.sourceforge.net/
+
+- Alejandro Pulver
+alejandro@varnet.biz
diff --git a/games/bomns/pkg-plist b/games/bomns/pkg-plist
new file mode 100644
index 000000000000..3ac45dbfbf4e
--- /dev/null
+++ b/games/bomns/pkg-plist
@@ -0,0 +1,31 @@
+bin/bomns
+%%EDITOR%%bin/bomnsedit
+%%LAUNCHER%%bin/bomnslauncher2
+%%DATADIR%%/graphics/editor_cursor.bmp
+%%DATADIR%%/graphics/editor_hud.bmp
+%%DATADIR%%/graphics/font.bmp
+%%DATADIR%%/graphics/hud.bmp
+%%DATADIR%%/graphics/intro.bmp
+%%DATADIR%%/graphics/objects.bmp
+%%DATADIR%%/graphics/players.bmp
+%%DATADIR%%/graphics/winscreen.bmp
+%%DATADIR%%/levels/faceoff.lvl
+%%DATADIR%%/levels/killyou.lvl
+%%DATADIR%%/levels/narrow.lvl
+%%DATADIR%%/levels/test.lvl
+%%DATADIR%%/sounds/beep.wav
+%%DATADIR%%/sounds/begin1.wav
+%%DATADIR%%/sounds/begin2.wav
+%%DATADIR%%/sounds/begin3.wav
+%%DATADIR%%/sounds/begin4.wav
+%%DATADIR%%/sounds/begin5.wav
+%%DATADIR%%/sounds/begin6.wav
+%%DATADIR%%/sounds/explosion.wav
+%%DATADIR%%/sounds/hurt.wav
+%%DATADIR%%/sounds/invulnerable.wav
+%%DATADIR%%/sounds/warp.wav
+%%DATADIR%%/sounds/winner.wav
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/levels
+@dirrm %%DATADIR%%/graphics
+@dirrm %%DATADIR%%