aboutsummaryrefslogtreecommitdiffstats
path: root/games/bovo-kde4/Makefile
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-02-23 03:03:17 +0800
committertcberner <tcberner@FreeBSD.org>2018-02-23 03:03:17 +0800
commitac5d54d2ae0d4bdb1d91507a4de47bc726e1c019 (patch)
tree3aad51132f546ad79059b32784badc3f6a42c8ff /games/bovo-kde4/Makefile
parentc5cfcc04963e6321cc90d144cb3bc9adbff4cf0f (diff)
downloadfreebsd-ports-gnome-ac5d54d2ae0d4bdb1d91507a4de47bc726e1c019.tar.gz
freebsd-ports-gnome-ac5d54d2ae0d4bdb1d91507a4de47bc726e1c019.tar.zst
freebsd-ports-gnome-ac5d54d2ae0d4bdb1d91507a4de47bc726e1c019.zip
Give the KDE SC4 applications ports a -kde4 suffix
In order to make room for the up-to-date version of the KDE Desktop and its applications move the KDE Application ports based on Qt4. PR: 225992 Exp-run by: antoine Reviewed by: rakuco, adridg Differential Revision: https://reviews.freebsd.org/D14413
Diffstat (limited to 'games/bovo-kde4/Makefile')
-rw-r--r--games/bovo-kde4/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/games/bovo-kde4/Makefile b/games/bovo-kde4/Makefile
new file mode 100644
index 000000000000..bbc0d98b63c0
--- /dev/null
+++ b/games/bovo-kde4/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= bovo
+PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 5
+CATEGORIES= games kde kde-kde4
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= ${${PORTNAME}_DESC}
+
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs libkdegames automoc4
+USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_CXXSTD= gnu++98
+
+.include <${.CURDIR}/../kdegames-kde4/Makefile.common>
+.include <bsd.port.mk>