aboutsummaryrefslogtreecommitdiffstats
path: root/games/brutalchess
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-02-09 06:36:23 +0800
committermiwi <miwi@FreeBSD.org>2007-02-09 06:36:23 +0800
commit8a763157e46f247a29790b41314bc48ef5d216d2 (patch)
tree5b7060666685abd16a7d9193461b47192b705e29 /games/brutalchess
parent0f487a5cc0f0a38f1f6477e725f2a79ac160f8dd (diff)
downloadfreebsd-ports-gnome-8a763157e46f247a29790b41314bc48ef5d216d2.tar.gz
freebsd-ports-gnome-8a763157e46f247a29790b41314bc48ef5d216d2.tar.zst
freebsd-ports-gnome-8a763157e46f247a29790b41314bc48ef5d216d2.zip
Brutal Chess features full 3D graphics, an advanced particle engine,
and several different levels of intelligent AI, inspired by the once popular "Battle Chess" released by Interplay circa 1988. WWW: http://brutalchess.sourceforge.net/ PR: ports/108904 Submitted by: Gustavo Perez Querol <gustau.perez at gmail.com>
Diffstat (limited to 'games/brutalchess')
-rw-r--r--games/brutalchess/Makefile33
-rw-r--r--games/brutalchess/distinfo3
-rw-r--r--games/brutalchess/files/patch-aclocal.m411
-rw-r--r--games/brutalchess/files/patch-install.sh254
-rw-r--r--games/brutalchess/pkg-descr5
-rw-r--r--games/brutalchess/pkg-plist29
6 files changed, 335 insertions, 0 deletions
diff --git a/games/brutalchess/Makefile b/games/brutalchess/Makefile
new file mode 100644
index 000000000000..4b81da89f442
--- /dev/null
+++ b/games/brutalchess/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Brutalchess
+# Date created: 2005-02-07
+# Whom: Gustavo Perez Querol <gustau.perez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= brutalchess
+PORTVERSION= 0.5.1
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-alpha-${PORTVERSION}-src
+
+MAINTAINER= gustau.perez@gmail.com
+COMMENT= Nice looking OpenGL chess game
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+CONFIGURE_TARGET= --target=${ARCH}-unknown-freebsd${OSREL}
+
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+
+USE_GL= yes
+USE_SDL= sdl image
+
+pre-build:
+ ${CHMOD} 0755 ${WRKSRC}/install-sh
+
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>
diff --git a/games/brutalchess/distinfo b/games/brutalchess/distinfo
new file mode 100644
index 000000000000..3df22f6bf1e1
--- /dev/null
+++ b/games/brutalchess/distinfo
@@ -0,0 +1,3 @@
+MD5 (brutalchess-alpha-0.5.1-src.tar.gz) = f600fd6181f7c69935dc4207aeb3a266
+SHA256 (brutalchess-alpha-0.5.1-src.tar.gz) = c265e88e51b8813e0b9e7daebec8b9af80da91be92b3d0fde7aad4983daf2922
+SIZE (brutalchess-alpha-0.5.1-src.tar.gz) = 7342080
diff --git a/games/brutalchess/files/patch-aclocal.m4 b/games/brutalchess/files/patch-aclocal.m4
new file mode 100644
index 000000000000..6e0f4e152eb0
--- /dev/null
+++ b/games/brutalchess/files/patch-aclocal.m4
@@ -0,0 +1,11 @@
+--- aclocal.m4.orig Tue Feb 6 23:28:00 2007
++++ aclocal.m4 Tue Feb 6 23:28:12 2007
+@@ -926,7 +926,7 @@
+ # restrict ourselves to GNU make (using the --version option ensures
+ # this.)
+ AC_DEFUN([AM_PROG_MKDIR_P],
+-[if mkdir -p --version . >/dev/null 2>&1 && test ! -d ./--version; then
++[if mkdir -p . >/dev/null 2>&1 && test ! -d ./--version; then
+ # Keeping the `.' argument allows $(mkdir_p) to be used without
+ # argument. Indeed, we sometimes output rules like
+ # $(mkdir_p) $(somedir)
diff --git a/games/brutalchess/files/patch-install.sh b/games/brutalchess/files/patch-install.sh
new file mode 100644
index 000000000000..565fec308210
--- /dev/null
+++ b/games/brutalchess/files/patch-install.sh
@@ -0,0 +1,254 @@
+--- install-sh.orig Sat Mar 11 01:36:44 2006
++++ install-sh Tue Feb 6 23:51:32 2007
+@@ -0,0 +1,251 @@
++#!/bin/sh
++#
++# install - install a program, script, or datafile
++# This comes from X11R5 (mit/util/scripts/install.sh).
++#
++# Copyright 1991 by the Massachusetts Institute of Technology
++#
++# Permission to use, copy, modify, distribute, and sell this software and its
++# documentation for any purpose is hereby granted without fee, provided that
++# the above copyright notice appear in all copies and that both that
++# copyright notice and this permission notice appear in supporting
++# documentation, and that the name of M.I.T. not be used in advertising or
++# publicity pertaining to distribution of the software without specific,
++# written prior permission. M.I.T. makes no representations about the
++# suitability of this software for any purpose. It is provided "as is"
++# without express or implied warranty.
++#
++# Calling this script install-sh is preferred over install.sh, to prevent
++# `make' implicit rules from creating a file called install from it
++# when there is no Makefile.
++#
++# This script is compatible with the BSD install script, but was written
++# from scratch. It can only install one file at a time, a restriction
++# shared with many OS's install programs.
++
++
++# set DOITPROG to echo to test this script
++
++# Don't use :- since 4.3BSD and earlier shells don't like it.
++doit="${DOITPROG-}"
++
++
++# put in absolute paths if you don't have them in your path; or use env. vars.
++
++mvprog="${MVPROG-mv}"
++cpprog="${CPPROG-cp}"
++chmodprog="${CHMODPROG-chmod}"
++chownprog="${CHOWNPROG-chown}"
++chgrpprog="${CHGRPPROG-chgrp}"
++stripprog="${STRIPPROG-strip}"
++rmprog="${RMPROG-rm}"
++mkdirprog="${MKDIRPROG-mkdir}"
++
++transformbasename=""
++transform_arg=""
++instcmd="$mvprog"
++chmodcmd="$chmodprog 0755"
++chowncmd=""
++chgrpcmd=""
++stripcmd=""
++rmcmd="$rmprog -f"
++mvcmd="$mvprog"
++src=""
++dst=""
++dir_arg=""
++
++while [ x"$1" != x ]; do
++ case $1 in
++ -c) instcmd="$cpprog"
++ shift
++ continue;;
++
++ -d) dir_arg=true
++ shift
++ continue;;
++
++ -m) chmodcmd="$chmodprog $2"
++ shift
++ shift
++ continue;;
++
++ -o) chowncmd="$chownprog $2"
++ shift
++ shift
++ continue;;
++
++ -g) chgrpcmd="$chgrpprog $2"
++ shift
++ shift
++ continue;;
++
++ -s) stripcmd="$stripprog"
++ shift
++ continue;;
++
++ -t=*) transformarg=`echo $1 | sed 's/-t=//'`
++ shift
++ continue;;
++
++ -b=*) transformbasename=`echo $1 | sed 's/-b=//'`
++ shift
++ continue;;
++
++ *) if [ x"$src" = x ]
++ then
++ src=$1
++ else
++ # this colon is to work around a 386BSD /bin/sh bug
++ :
++ dst=$1
++ fi
++ shift
++ continue;;
++ esac
++done
++
++if [ x"$src" = x ]
++then
++ echo "install: no input file specified"
++ exit 1
++else
++ true
++fi
++
++if [ x"$dir_arg" != x ]; then
++ dst=$src
++ src=""
++
++ if [ -d $dst ]; then
++ instcmd=:
++ chmodcmd=""
++ else
++ instcmd=mkdir
++ fi
++else
++
++# Waiting for this to be detected by the "$instcmd $src $dsttmp" command
++# might cause directories to be created, which would be especially bad
++# if $src (and thus $dsttmp) contains '*'.
++
++ if [ -f $src -o -d $src ]
++ then
++ true
++ else
++ echo "install: $src does not exist"
++ exit 1
++ fi
++
++ if [ x"$dst" = x ]
++ then
++ echo "install: no destination specified"
++ exit 1
++ else
++ true
++ fi
++
++# If destination is a directory, append the input filename; if your system
++# does not like double slashes in filenames, you may need to add some logic
++
++ if [ -d $dst ]
++ then
++ dst="$dst"/`basename $src`
++ else
++ true
++ fi
++fi
++
++## this sed command emulates the dirname command
++dstdir=`echo $dst | sed -e 's,[^/]*$,,;s,/$,,;s,^$,.,'`
++
++# Make sure that the destination directory exists.
++# this part is taken from Noah Friedman's mkinstalldirs script
++
++# Skip lots of stat calls in the usual case.
++if [ ! -d "$dstdir" ]; then
++defaultIFS='
++'
++IFS="${IFS-${defaultIFS}}"
++
++oIFS="${IFS}"
++# Some sh's can't handle IFS=/ for some reason.
++IFS='%'
++set - `echo ${dstdir} | sed -e 's@/@%@g' -e 's@^%@/@'`
++IFS="${oIFS}"
++
++pathcomp=''
++
++while [ $# -ne 0 ] ; do
++ pathcomp="${pathcomp}${1}"
++ shift
++
++ if [ ! -d "${pathcomp}" ] ;
++ then
++ $mkdirprog "${pathcomp}"
++ else
++ true
++ fi
++
++ pathcomp="${pathcomp}/"
++done
++fi
++
++if [ x"$dir_arg" != x ]
++then
++ $doit $instcmd $dst &&
++
++ if [ x"$chowncmd" != x ]; then $doit $chowncmd $dst; else true ; fi &&
++ if [ x"$chgrpcmd" != x ]; then $doit $chgrpcmd $dst; else true ; fi &&
++ if [ x"$stripcmd" != x ]; then $doit $stripcmd $dst; else true ; fi &&
++ if [ x"$chmodcmd" != x ]; then $doit $chmodcmd $dst; else true ; fi
++else
++
++# If we're going to rename the final executable, determine the name now.
++
++ if [ x"$transformarg" = x ]
++ then
++ dstfile=`basename $dst`
++ else
++ dstfile=`basename $dst $transformbasename |
++ sed $transformarg`$transformbasename
++ fi
++
++# don't allow the sed command to completely eliminate the filename
++
++ if [ x"$dstfile" = x ]
++ then
++ dstfile=`basename $dst`
++ else
++ true
++ fi
++
++# Make a temp file name in the proper directory.
++
++ dsttmp=$dstdir/#inst.$$#
++
++# Move or copy the file name to the temp name
++
++ $doit $instcmd $src $dsttmp &&
++
++ trap "rm -f ${dsttmp}" 0 &&
++
++# and set any options; do chmod last to preserve setuid bits
++
++# If any of these fail, we abort the whole thing. If we want to
++# ignore errors from any of these, just make sure not to ignore
++# errors from the above "$doit $instcmd $src $dsttmp" command.
++
++ if [ x"$chowncmd" != x ]; then $doit $chowncmd $dsttmp; else true;fi &&
++ if [ x"$chgrpcmd" != x ]; then $doit $chgrpcmd $dsttmp; else true;fi &&
++ if [ x"$stripcmd" != x ]; then $doit $stripcmd $dsttmp; else true;fi &&
++ if [ x"$chmodcmd" != x ]; then $doit $chmodcmd $dsttmp; else true;fi &&
++
++# Now rename the file to the real destination.
++
++ $doit $rmcmd -f $dstdir/$dstfile &&
++ $doit $mvcmd $dsttmp $dstdir/$dstfile
++
++fi &&
++
++
++exit 0
diff --git a/games/brutalchess/pkg-descr b/games/brutalchess/pkg-descr
new file mode 100644
index 000000000000..481366d27c6b
--- /dev/null
+++ b/games/brutalchess/pkg-descr
@@ -0,0 +1,5 @@
+Brutal Chess features full 3D graphics, an advanced particle engine,
+and several different levels of intelligent AI, inspired by the once
+popular "Battle Chess" released by Interplay circa 1988.
+
+WWW: http://brutalchess.sourceforge.net/
diff --git a/games/brutalchess/pkg-plist b/games/brutalchess/pkg-plist
new file mode 100644
index 000000000000..03adb9d826a7
--- /dev/null
+++ b/games/brutalchess/pkg-plist
@@ -0,0 +1,29 @@
+bin/brutalchess
+libexec/md3view
+libexec/objview
+%%DATADIR%%/art/brutalchesslogo.png
+%%DATADIR%%/art/marblehugeblack.png
+%%DATADIR%%/art/marblehugewhite.png
+%%DATADIR%%/doc/AUTHORS
+%%DATADIR%%/doc/COPYING
+%%DATADIR%%/doc/ChangeLog
+%%DATADIR%%/doc/INSTALL
+%%DATADIR%%/doc/NEWS
+%%DATADIR%%/doc/README
+%%DATADIR%%/fonts/COOLVETI.TTF
+%%DATADIR%%/fonts/Ghostwri.ttf
+%%DATADIR%%/fonts/VeraMono.ttf
+%%DATADIR%%/fonts/ZEROES__.TTF
+%%DATADIR%%/models/bishop.obj
+%%DATADIR%%/models/debug.obj
+%%DATADIR%%/models/king.obj
+%%DATADIR%%/models/knight.obj
+%%DATADIR%%/models/pawn.obj
+%%DATADIR%%/models/queen.obj
+%%DATADIR%%/models/rook.obj
+share/nls/POSIX
+share/nls/en_US.US-ASCII
+@dirrm share/brutalchess/art
+@dirrm share/brutalchess/doc
+@dirrm share/brutalchess/fonts
+@dirrm share/brutalchess/models