aboutsummaryrefslogtreecommitdiffstats
path: root/games/bsdgames/files
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2003-08-14 23:15:51 +0800
committerglewis <glewis@FreeBSD.org>2003-08-14 23:15:51 +0800
commitb72479910fa320d138a253cc3719f4a47d7bd828 (patch)
tree5af9c27dfae1c8235fd670317eca56c3b23f0efb /games/bsdgames/files
parent4751d622fa6744c94202744a54da9827a423ca39 (diff)
downloadfreebsd-ports-gnome-b72479910fa320d138a253cc3719f4a47d7bd828.tar.gz
freebsd-ports-gnome-b72479910fa320d138a253cc3719f4a47d7bd828.tar.zst
freebsd-ports-gnome-b72479910fa320d138a253cc3719f4a47d7bd828.zip
. Enable rogue.
Diffstat (limited to 'games/bsdgames/files')
-rw-r--r--games/bsdgames/files/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/bsdgames/files/Makefile b/games/bsdgames/files/Makefile
new file mode 100644
index 000000000000..ca13bede5c11
--- /dev/null
+++ b/games/bsdgames/files/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+.include "Makefile.inc"
+
+GAMES= adventure arithmetic atc backgammon battlestar bs canfield cribbage \
+ fish hack hangman larn mille phantasia piano pig quiz robots rogue \
+ sail snake trek worm wump
+all: ${GAMES}
+.for I in ${GAMES}
+ cd ${I} && make depend && make all
+.endfor
+
+install: ${GAMES}
+ mtree -deU -f var.mtree -p ${VARDIR}
+ mtree -deU -f share.mtree -p ${SHAREDIR}
+.for I in ${GAMES}
+ cd ${I} && make install
+.endfor
+
+clean: ${GAMES}
+.for I in ${GAMES}
+ cd ${I} && make clean
+.endfor
+
+extract: ${GAMES}
+
+.for I in ${GAMES}
+${I}:
+ cvs -d `pwd`/cvs get ${I}
+.endfor
+
+commit:
+.for I in ${GAMES}
+ cvs -d `pwd`/cvs commit -F ./commitmsg ${I}
+.endfor
+
+distclean:
+ rm -rf ${GAMES}