aboutsummaryrefslogtreecommitdiffstats
path: root/games/bsdgames
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2004-01-23 03:41:36 +0800
committerglewis <glewis@FreeBSD.org>2004-01-23 03:41:36 +0800
commitd9efe7cf19aa56a0ba067bd42bc66c981d14372c (patch)
tree595632c318aaa217862c71798c927763836d8b83 /games/bsdgames
parentb85ec5257d70e8dd271e9e64c0e4320a47d4a442 (diff)
downloadfreebsd-ports-gnome-d9efe7cf19aa56a0ba067bd42bc66c981d14372c.tar.gz
freebsd-ports-gnome-d9efe7cf19aa56a0ba067bd42bc66c981d14372c.tar.zst
freebsd-ports-gnome-d9efe7cf19aa56a0ba067bd42bc66c981d14372c.zip
. Patch the paths in a number of source files to respect ${PREFIX}. Not
only were they hardwired, they were hardwired incorrectly (the prefix was set to /usr/local/local/local). Reported and tested by: Alexandr Kovalenko <never@nevermind.kiev.ua>
Diffstat (limited to 'games/bsdgames')
-rw-r--r--games/bsdgames/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/games/bsdgames/Makefile b/games/bsdgames/Makefile
index 146649d406bf..a9a3ef997316 100644
--- a/games/bsdgames/Makefile
+++ b/games/bsdgames/Makefile
@@ -7,7 +7,7 @@
PORTNAME= freebsd-games
PORTVERSION= 5.1.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=markm
@@ -48,6 +48,14 @@ MAN6= \
MANCOMPRESSED= maybe
+PATHNAME_FILES= atc/pathnames.h \
+ cribbage/pathnames.h \
+ fish/pathnames.h \
+ larn/pathnames.h \
+ quiz/datfiles/index \
+ quiz/pathnames.h \
+ wump/pathnames.h
+
post-extract:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} extract)
@@ -56,8 +64,10 @@ post-patch:
@${FIND} ${WRKSRC} -name '*.c' -or -name '*.h' -or -name '*.6' -or \
-name 'index' | ${XARGS} ${REINPLACE_CMD} -e \
's|share/games|local/share/games|g'
- @${REINPLACE_CMD} -e 's|/usr/local/local/local|${PREFIX}|g' \
- ${WRKSRC}/quiz/pathnames.h ${WRKSRC}/quiz/datfiles/index
+ @for file in ${PATHNAME_FILES}; do \
+ ${REINPLACE_CMD} -e 's|/usr/local/local/local|${PREFIX}|g' \
+ ${WRKSRC}/$${file}; \
+ done
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
"${WRKSRC}/hack/hack.unix.c"